3

I've bought a wifi adapter for raspberry pi, I don't have an OS, I'm running RetroPie so I need a console solution.

Someone suggested accessing:

sudo nano /etc/network/interfaces

and changing it to:

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

iface wlan0 inet dhcp
    wpa-ssid "ssid"
    wpa-psk "password"

I then reset my device like told and inserted the wifi adapter.

After booting up I don't know what else to do now to connect with wifi...

Any ideas?

2

This applies to Raspbian Wheezy prior to 2015-05-05 for later (and Jessie) See How do I set up networking/WiFi/Static IP

You can do this but I would suggest /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface home inet dhcp
iface default inet dhcp

And put network in /etc/wpa_supplicant/wpa_supplicant.conf Mine is:-

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    scan_ssid=1
    ssid="*****"
    psk="*****"
    id_str="home"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
    eap=MD5
}

You may need to customise settings depending on your WiFi. Check out man wpa_supplicant.conf

| improve this answer | |
  • I've tried something similar to this but my wifi dongle doesn't flash at all when it's in my Pi but it does in my PC. Do I need drivers sorted first? is that my problem? – SaturnsEye Sep 19 '14 at 9:37
  • Unless you have a B+ you probably don't have enough power. Use a powered hub. – Milliways Sep 19 '14 at 10:30
  • I do have the B+ – SaturnsEye Sep 19 '14 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.