0

I have Raspberry Pi B+, connected to LAN and I can communicate with WAN without any problems. However, I've installed Samba using following configuration (smb.conf):

#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
   workgroup = WORKGROUP
   security = user
   map to guest = Bad User

#============================ Share Definitions ==============================
[measurements]
   comment = Pidaq Measurements Folder
   browseable = yes
   writable = yes
   guest ok = yes
   path = /mnt/data

The rPi B+ gets IP, I can ping it on LAN, I can logon via SSH, but I cannot see the share on network. The /mnt/data partition configration has been dounble checked and works ok. I am using Archlinux and now I can see it in Windows Explorer, but If I click on it, I get following Windows 7 error:Cannot access Samba Share

  • did you try accessing by IP i.e.: \\<ip_address>\measurements\ – jet Sep 22 '14 at 21:41
  • Is the computer set to discover network shares? (Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings) - check that discovery is turned on and that file and printer sharing is also turned on for whichever network you are on. – user2813274 Sep 23 '14 at 2:28
  • have you restarted samba? or rebooted the pi? is samba running? – Steve Robillard Sep 24 '14 at 18:25
0

It is solved! I've added umask=022 to shared folder description, restared samba and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.