1

I've been trying to connect my Pi to my Mac using a USB-TTL cable. I followed this tutorial. On the terminal I get nothing when the Pi connects (not even sure if it connects at all). I've tried everything:

  • checked the connection with the GPIO pins
  • launched the terminal well after the Pi booted
  • tried CoolTerm: it seems to connect but the screen is blank (just like with the terminal)
  • tried two different SD cards
  • tried two different laptops (Mavericks and Snow Leo
  • checked the driver on both laptops: when the TTL cable is connected it appears in both the terminal (ls /dev/tty.*) and in the System Profiler
  • tried both 'screen /dev/tty.usbserial 115200' and the screen /dev/tty.PL2303-000014FA 115200
  • tried replacing 'tty' with 'cu'
  • remove WIFI dongle

Still no luck. What did I do wrong?

Update: hooked up a logic analyzer to the TX pin and got no signal during booting and when doing a serial test. Is there any reason why the UART wouldn't work?

Update2: disabled the boot messages and the login using this tutorial and hoked up an arduino to the pi (important: the Pi's GND must be connected to the Arduino's GND pin). The arduino sends a single character and echos everything back. Once I fired up minicom and with the right Baud-rate, I could see the characters coming in and all the typed characters being echoed back. So the UART works but it won't send any boot messages or allow login with a console.

  • One end is USB, the other is TTL. Can you confirm you are inserting the USB into the Mac and the TTL into the Pi. Is the TTL level 3.3V? Precisely what connections have you made to the Pi? – joan Sep 24 '14 at 15:25
  • It's a 3.3V cable, exactly like the one pictured here:learn.adafruit.com/… – alkopop79 Sep 24 '14 at 15:30
  • The connection is the same as in the tutorial mentioned here:learn.adafruit.com/… – alkopop79 Sep 24 '14 at 15:31
  • 1
    Do sudo su to become root. When you're sorted you should add yourself to the tty group (sudo adduser pi tty). – joan Sep 24 '14 at 16:51
  • 1
    Then swap TX and RX at the Pi end. Some Adafruit cables were mislabelled. – joan Sep 24 '14 at 16:53
1

For me, the blank screen was a matter of timing. I had the USB power connected to the GPIO 5v, so connecting the serial interface to a USB powered hub (connected to an iMac), immediately booted the Pi to the point at which it hung (something wrong on the RasPi initialization on the SD card). So, then opening a screen session in OS X Terminal showed — nothing! There was nothing happening at that moment, the Pi was hung — but the USB serial setup was working.

I discovered this by first opening a screen session on the iMac, then plugging in the Pi, either through an external power supply, or by connecting the 5v (red) connector (but not both!). The Terminal screen session (or an alternative, such as CoolTerm) filled with data, to the point at which the Pi hung. And as we were trying to troubleshoot the defective SD setup, we had what we wanted. It was all a matter of timing — at least, for me. I hope that helps!

0

Never managed to sort this one out. I've tried different cables, different setups, two SD cards, etc. It simply doesn't work. I even checked the TX pin of the Pi with a logic analyser during and after boot and I got nothing. Needless to say I've the settings such as the login at boot. Nothing. Interestingly the serial port works fine, tested it with an Arduino. Conclusion: there's a bug in RasPi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.