I bought a generic Wi-Fi dongle that, according to the comments of the people who bought it, worked out of the box on Raspbian. Well, turns out it didn't. I'm struggling to make it work. I'm using Raspbian 3.10.25 on a Model B via ssh.


lo        no wireless extensions.

eth0      no wireless extensions.

I first suspected there was a missing firmware. lsusb identifies the device as 148f:7601 Ralink Technology, Corp. firmware-ralink was indeed installed out of the box, and according to some forum posts that indeed is the firmware for devices with 148f:7601 Ralink id. So I guess the modules should be loaded... lsmod | grep -v snd:

Module                  Size  Used by
leds_gpio               2059  0 
led_class               3688  1 leds_gpio

Apart from the sound modules only the LED modules are loaded. I guess there's something wrong with that... I tried loading some available modules... ls /lib/modules/3.10.25+/kernel/drivers/net/wireless/:

at76c50x-usb.ko  b43        hostap    libertas_tf        mwifiex  rndis_wlan.ko  rtl818x    zd1201.ko
ath              b43legacy  libertas  mac80211_hwsim.ko  p54      rt2x00         rtl8192cu  zd1211rw

I tried modprobing everything in there with a "rt" prefix, wlan0 still didn't show on iwconfig.

I'm at loss. Any ideas? The dongle came with a "driver" DVD. It consists of multiple folders of what seem to be multiple drivers for several different hardware. The documentation is missing for most of them and incorrect for the ones it's present. I tried to unzip and then make && make install everything under the "Linux" directory that didn't have "Android" in the filename, but make gives several errors and editing the makefiles without a manual would be challenging.


1 Answer 1


It's not worth spending time trying to get this WiFi dongle working. It takes too many steps and all that effort goes down the drain everytime the kernel or anything else gets updated.

Your best option is to return/sell/throw the Ralink 7601 and get an RTL8188CUS-based dongle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.