1

I'm on a Mac and using Ethernet through a thunderbolt adapter. I use Raspbian Debian Wheezy 2014-09-09. I'm using VirtualBox (program) for school, and Cyberduck to setup the SSH connection. I'm supposed to use this method:

$ ssh -l pi 192.168.1.1 

It will ask for my password, which is still the default. However, my computer won't recognize the Pi. I then used:

$ ssh -v pi 192.168.1.1

it showed this:

debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
ssh: Could not resolve hostname pi: Name or service not known

EDIT HERE Okay, so I followed a PDF from my school to set up a virtual machine. The program to make this is Virtualbox. That virtual machine runs on Debian. I've set up Debian and I was at the final step, giving the raspberry an IP address. I needed to shut off my ethernet cables ipv4 automatic configure and give the raspberry the ip address: 192.168.1.1. I did that with the code

root@debianrouter:~# ssh -l pi 192.168.1.1

than i get this:

pi@192.168.1.1's password:

I should be able to type the password: raspberry

Raspbian's default password but when I type that it doesn't work. I get this: Permission denied, try again and that's where I'm stuck. So I tried to get the debug things with

root@debianrouter:~# ssh -v pi 192.168.1.1

and that's where I'm stuck, I don't know what to do. I expect to just write:

raspberry

and it should answer like this: look at the screenshot near/under 92.

enter image description here Everything above is done on the Virtual machine.

22
  • 1
    Try ssh pi@192.168.1.1 Are you sure your Pi's IP is 192.168.1.1?
    – tmartin
    Sep 25 '14 at 15:05
  • eth1 gives me back with the ifconfig command that it is my IP address. It's my inet addr
    – jrust
    Sep 25 '14 at 15:08
  • If I use my password it will give me: Permission denied, try again
    – jrust
    Sep 25 '14 at 15:09
  • On which device did you execute eth0?
    – tmartin
    Sep 25 '14 at 15:09
  • 1
    @jrust The message Permission denied, try again not only means that the password you entered is wrong, but also that you are connected to your Pi. Do you have a keyboard layout different than QWERTY? If so, have a look to this anwser. Sep 25 '14 at 15:12
1

The problem here is that the LAN connection can retrieve an IP Address (192.168.1.1). You have to turn IPv4 off in settings (for@jrust, check iArch_week3 @87) , so the virtual machine gives the Raspberry its own IP, in our case 192.168.1.100.

In Windows, we have to turn off IPv4 and v6 in order to ssh into our Raspberry.

Hope it helps..

3

First of all 192.168.1.1 is very likely not to be the pi's IP address but the one of your router. So, if you have access to the Pi then in terminal type "hostname -I" and the ip returned should probably have a two or three digit number at the end something like 192.168.1.10 or 192.168.1.100 this is the IP address you should put into the terminal on the Mac ssh pi@the-pi's-ip

Hope this helps

2

At least you have given some detail, but what you are trying just introduces too much complication.

You should try (from a terminal on the Mac):-
ssh pi@IPaddress

It is almost certain that the Pi's address is NOT 192.168.1.1, as this is most likely the gateway. You can check this by typing netstat -nr(in a terminal on the Mac).

If the Mac (is it yours or shared) has nmap installed nmap -sP 192.168.1.* would show all the active addresses on your network.

Not the answer you're looking for? Browse other questions tagged or ask your own question.