0

I'm trying to install mopidy on my Pi running raspbmc but it complains about missing LSB script:

$ sudo apt-get install mopidy
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  gstreamer0.10-plugins-good libtag1-vanilla libtag1c2a
Suggested packages:
  mopidy-doc
The following NEW packages will be installed:
  gstreamer0.10-plugins-good libtag1-vanilla libtag1c2a mopidy
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 162 kB/2259 kB of archives.
After this operation, 7107 kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://archive.raspbian.org/raspbian/ testing/main mopidy all 0.19.4-2 [162 kB]
Fetched 162 kB in 0s (291 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libtag1-vanilla:armhf.
(Reading database ... 47766 files and directories currently installed.)
Unpacking libtag1-vanilla:armhf (from .../libtag1-vanilla_1.7.2-1_armhf.deb) ...
Selecting previously unselected package libtag1c2a:armhf.
Unpacking libtag1c2a:armhf (from .../libtag1c2a_1.7.2-1_armhf.deb) ...
Selecting previously unselected package gstreamer0.10-plugins-good:armhf.
Unpacking gstreamer0.10-plugins-good:armhf (from .../gstreamer0.10-plugins-good_0.10.31-3
+nmu1_armhf.deb) ...
Selecting previously unselected package mopidy.
Unpacking mopidy (from .../mopidy_0.19.4-2_all.deb) ...
Setting up libtag1-vanilla:armhf (1.7.2-1) ...
Setting up libtag1c2a:armhf (1.7.2-1) ...
Setting up gstreamer0.10-plugins-good:armhf (0.10.31-3+nmu1) ...
Setting up mopidy (0.19.4-2) ...
insserv: dryrun, not creating .depend.boot, .depend.start, and .depend.stop
update-rc.d: error: cannot find a LSB script for mopidy
dpkg: error processing mopidy (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mopidy
E: Sub-process /usr/bin/dpkg returned an error code (1)

Would be grateful for help.

  • I assume other packages do not show this error during installation with apt-get? – Ghanima Oct 1 '14 at 8:00
  • @Ghanima They don't. I tried installing nginx and adding it via update-rc.d and it worked fine. – Mikołaj Pastuszko Oct 1 '14 at 20:52
0

I finally managed to solve the problem by extracting deb package and manually copying mopidy boot script to /etc/init.d/mopidy. I also had to manually adjust init script links using update-rc.d and insserv, because the symlinks weren't removed when uninstalling mopidy via apt-get remove.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.