2

I purchased a 4 digit 7 segment display from adafruit and got it working on my old model A running adafruit occidentalis operating system. I recently bought a model B+ and installed the latest version of rasbian. I went through the instructions to enable i2c, installed python-smbus, and i2c-tools, and can run i2cdetect. However, I was never able to make the display work with the model B+, can't even see it on i2cdetect, just get UU in a couple places because it's looking for some wolfson card that I don't own.

I have been working with Adafruit tech support but they have stopped responding. I measured voltages on the GPIO pins the display uses, and everything looks right except the scl pin, which should give 3.3v, but instead gives almost 0v. I was concerned the pin might not be working, so I ran a script adafruit gave me to turn the pin on and off every 2 seconds, and I measured the right voltage while doing that, so I think the pin is ok, but still not working right.

Since the display lights up on the model A, I don't think it's a soldering issue. Since adafruit tech support has stopped talking to me, I thought I'd try here. Let me know if there are any commands I should run or files I should check and put the results here. I'm not an expert at this and don't have the time to become one, I'm supposed to be writing my thesis.

Here is an image of the pins on the B+. I flagged them to easily identify them. Red is VCC, Yellow is SDA, Green is SCL, and orange is GND. Adafruit never said it wouldn't work on a B or B+.

enter image description here

Finally got this fixed. Had to replace the raspberry pi, the pin was damaged. The display worked immediately when I got it on a new computer with a working pin. Sorry about the delay.

  • 1
    By model A you mean a Pi without an Ethernet port and one USB socket? Do Adafruit say it should work with a model B? Could you edit your post and include the following information: What pins have you connected between the device and the Pi? What does i2cdtect -y 0 and i2cdetect -y 1 report? What is reported by ls -l /dev/i2c* – joan Oct 3 '14 at 21:28
  • Yes, that's what my model A looks like. Adafruit never said it wouldn't work on model B or B+, this particular LED backpack should work on raspberry pi or arduino. I added a picture to show what pins I'm using. i2cdetect -y 0 doesn't work because I'm using a model B+, and the i2c device was switched to 1 when they started making new revision model B. i2cdetect -y 1 reports UU on line 10 column B and line 30 column B ( I think, can't check it right now ), but these are related to the wolfson audio card that the newer raspbian versions look for by default now. Everything else comes up blank. – user137 Oct 3 '14 at 21:39
  • Additionally, the model A shows a 00 in line 70 column 0 when the display is hooked up correctly. – user137 Oct 3 '14 at 21:40
  • Are you powering from 3V3? Have you tried from a 5V pin? – joan Oct 3 '14 at 21:47
  • 1
    I can't see how 5V can get to the SCL (I presume you mean) on the Pi. Surely the LCD unit is designed to work on 5V. It would be nice to see the i2cdetect listing as well as the result of ls -l /dev/i2c*. – joan Oct 4 '14 at 6:58
0

I solved this by replacing the Pi. The pin was damaged after all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.