0

I just got my B+, and installed the newest version of Rapsbian. I am using an adapter box display it on my VGA monitor. For some reason, when I try to adjust the overscanning variables in config.txt, they don't change. This is my current config file:

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
overscan_left=-30
overscan_right=-30
overscan_top=-30
overscan_bottom=-30

# uncomment to force a console size. By default it will be display's size minus
# overscan.
framebuffer_width=800
framebuffer_height=600

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=14

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# for more options see http://elinux.org/RPi_config.txt
gpu_mem=64
core_freq=500
sdram_freq=600
over_voltage=6
1

The setting hdmi_safe=1 tells the Pi to use HDMI, it also sets a number of other options you don't want.

Whereas the setting hdmi_force_hotplug=1 just tells the Pi to use HDMI even if no HDMI monitor is detected.

So:

  1. comment out #hdmi_safe=1 (add the #)

  2. uncomment hdmi_force_hotplug=1 (remove the #)

Reboot and you should get a picture. You should then be able to set your resolution for your monitor by adjusting the width and height values in the following two lines accordingly.

framebuffer_width=800
framebuffer_height=600

Full information can be found here: http://elinux.org/RPiconfig

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.