2

I tried to update my PI with sudo apt-get update && sudo apt-get upgrade. However I get errors...

The following packages have unmet dependencies:
 xserver-xorg-core : Depends: xserver-common (>= 2:1.12.4-6+deb7u2) but 2:1.12.4-6 is installed
                     Recommends: libgl1-mesa-dri (>= 7.10.2-4) but it is not installed

I tried running apt-get -f install but I get more errors...

Preparing to replace xserver-common 2:1.12.4-6 (using .../xserver-common_2%3a1.12.4-6+deb7u2_all.deb) ...
Unpacking replacement xserver-common ...
dpkg: error processing /var/cache/apt/archives/xserver-common_2%3a1.12.4-6+deb7u2_all.deb (--unpack):
 trying to overwrite '/var/lib/xkb', which is also in package x11-xkb-utils 7.7~1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/xserver-common_2%3a1.12.4-6+deb7u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

According to this: http://www.raspberrypi.org/documentation/raspbian/updating.md maybe I need to update xserver manually. This is getting a bit out of my depth. Can anyone help? (if you know of a link that explains what to do that would be fine).

2

Try to install aptitude which solves those problems more often

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.