1

I'm trying to connect a BT USB dongle to anything. Once paired, on my Mac (Mac OS X 10.9) I get 'Bluetooth serial failure has occurred. Failed to open RFCOMM serial channel'. It also pairs with my mobile but cannot connect. I've tried to:

  • edit the RFCOMM config file where I added my laptop's MAC address and tried different channel numbers from 1-3. Then I did sudo rfcomm bind all

  • connect with a different laptop. It seems that whatever device is paired with the BT dongle, they cannot connect

Also, when my Mac's BT is on, the dongle keeps trying to connect and gives me the above mentioned error message. The Pi's BT dongle does appear in the system profiler though.

I've been trying to fix it for three days. Please someone help!

UPDATE: Re-installed the image of the Pi and the problem still persist: I can pair the dongle with anything but cannot create any kind of connection while on my Mac I get the usual serial error message (EVERY 30 SECONDS!!!). This is what the System Profiler says about the dongle, note that it doesn't mention 'serial' among the services:

 raspberrypi-0:
  Address:  00-15-83-0C-BF-EB
  Major Type:   Desktop
  Minor Type:   Computer
  Services: OBEX Object Push, Hands-Free Audio Gateway, AVRCP TG, AVRCP CT, SIM Access Server, Dial-Up Networking, Headset Audio Gateway
  Paired:   No
  Configured:   No
  Connected:    Yes
  Manufacturer: Cambridge Silicon Radio (0x3, 0xC5C)
  Class of Device:  0x01 0x01 0x0104
  AFH:  On
  AFH Map:  0000F0FFFFFFFF7F
  RSSI: -81
  Role: Master
  EDR Supported:    No
  eSCO Supported:   No
  SSP Supported:    No
  • 1
    After days of trying it still doesn't work. I've managed to pair the dongle with different laptops and my mobile but cannot create connection. On my Macbook I can also see that the dongle keeps trying to connect. – alkopop79 Oct 11 '14 at 16:58
0

The first issue you should look at is the power supply. In any kind of RF device, it may be possible to make initial connection with fairly low amount of energy available, but when the "serious" data transfer starts, it just might be too little to power the device.

Please use at least 2A power supply, if you already aren't. Even better, measure the voltage on the BT dongle's power terminals. Or use external (powered) USB hub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.