I am trying to connect to my headless RaspberryPi using SSH via putty but have some networking problems, although it used to work sometimes.

The Pi is running Raspbian and is connected to my router with an ethernet cable. In '/boot/cmdline.txt' I have added ip=[RandomIP] so it now looks like this:

dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait ip=

But when I ping that IP with a laptop (connected with W-Lan, so it should be the same network) to check it, it doesn't respond and with putty I of course get a timeout error.

Here is the output of "ipconfig", I'm sorry it's not english, perhaps some of you can read it though:


Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung:

   Verbindungsspezifisches DNS-Suffix: 
   Verbindungslokale IPv6-Adresse  . : fe80::2448:1306:b3f6:3dd%12
   IPv4-Adresse  . . . . . . . . . . :
   Subnetzmaske  . . . . . . . . . . :
   Standardgateway . . . . . . . . . :

Tunneladapter Teredo Tunneling Pseudo-Interface:

   Verbindungsspezifisches DNS-Suffix: 
   IPv6-Adresse. . . . . . . . . . . : 2001:0:9d38:6abd:2081:ab3:3f57:fd8a
   Verbindungslokale IPv6-Adresse  . : fe80::2081:ab3:3f57:fd8a%13
   Standardgateway . . . . . . . . . : ::

Tunneladapter 6TO4 Adapter:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix: 

Tunneladapter isatap.{F887DD4E-BA4E-468A-A603-1DA21AD0DC84}:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix: 

Unfortunately my Router has no DHCP so I can't check if the IP really is the one I've set, but I actually think so.

I have already set up Raspbian again several times, but didn't get any further. Also I tried connecting it directly to my laptop - Again, first it worked, but after reinstalling Raspbian (for other reasons) I had the same problem.

So I can't figure out what to do now. My Goal is of course to connect to it with a SSH client, which is currently not working (it doesn't even respond on ping).

  • 1
    What is your goal? If you just want to see if the RPi is on the specific IP, try to scan it using nmap
    – Jervelund
    Commented Oct 12, 2014 at 23:04
  • Post the contents of your `cmdline.txt' (otherwise we are just guessing). Also post the IP settings of your laptop.
    – Milliways
    Commented Oct 13, 2014 at 4:01
  • Sorry, I could have added more information, hope that helps you now.
    – Pete
    Commented Oct 13, 2014 at 15:52

1 Answer 1


OK, it works now. I've installed a nice tool named "Fing" on my android phone and immediately found out the pi's ip, which was not the one I've set, so I edited the cmdline.txt with SSH and found out that the ip was set in the second line, so I changed it and rebooted and it works just fine!

There is also a good RPi-Doc article about this problem. It describes how to use nmap to scan your local network and find the Pi's ip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.