ok so my raspberry pi b+ just came and I started it up and the NOOBS stuff came up I selected raspbian and installed it. When it boots it works for about 3 seconds and stops on a kernel panic.

Kernel panic-not syncing:
VFS: unable to mount root fs on unknown- block(179,2)

then comes a body of text that I don't really understand and the whole system freezes. I tried again just plugging in the power supply and hdmi and still nothing.

  • I'm getting this and I just verified that it is NOT my sd card by installing NOOBS via the same SD card. That also checks out for any power issues as well. Either the img is bad (doubtful) or a lot of people are formatting the card wrong.
    – Jacksonkr
    Mar 13, 2015 at 16:52
  • I have the same issue and am wondering if one of the answers above was the correct answer. Perhaps Peter Agurkis is willing to share the solution just like he did with the problem.
    – user28674
    Apr 4, 2015 at 14:30

7 Answers 7


It is probably SD card corruption, which is often caused by not shutting down correctly. To shut down correctly you need to either from the desktop use the power icon, or from the terminal/SSH do sudo poweroff. You will have to reinstall NOOBS, and maybe get a new SD card.


I will focus on the error. "VFS: unable to mount root fs on unknown- block(179,2)" means that Linux did not find a valid root file system. This root file system is required so that Linux can start the login prompt and other processes. The core registers are then dumped in a panic log.

This error can happen
1. if you pass an incorrect commandline parameter to Linux. This could lead to an unknown driver being used or a totally non-existent device. If your Raspbian install was perfect then there should be no issues here.
2. if the root filesystem is broken. After you've verified that the commandline parameters are correct then the root filesystem would only be broken if there is actual HW issue (sub optimal power, or low grade SD card, or uncorrectable data that was written on a bad block on a flash device).


sounds like power issues.

Please unplug everything and check the power test points.

Its also worth noting that USB power plugs often fail to supply the require 5v EVEN if they are labelled to do such.

My own experiments showed that a difference of just 0.15v(avg) was enough to cause sporadic stability issues, that would affect the image on the SD card.


I had a similar problem on my Raspberry Pi and it turned out to be the SD card. It would probably be worth trying with another card to see if it can boot from that.


I solved this issue using an 8GB SD card. I used to copy an image of Raspbian (2012 version) that fits in a 2GB SD card for the first versions of Raspberry board. But with Raspberry Pi 2, when I try to use the new version of Raspbian (2015) with the same SD card, the comand dd works but says nothing about the smaller size of SD card. If you look at the size of the image of Raspbian 2015 versions is about 3.1GB, and is better to use a 8GB SD card.


I had exactly this problem - after rebooting one time whilst on the machine headless through SSH I never regained my connection, and had to view my PI via the TV - which is where I saw the message. I had no response from the keyboard. In my case it was a power issue. I have a powered USB hub connected to the PI, but my power-cable wasn't in for some reason. Everything was trying to run off just the PI's power. Prior to reboot it must have been just about clinging on to power, as it had been working.


I had exactly the same error after new software installation, here is what fixed the problem (found here):

  • Hold Shift button during the start-up
  • Find the cmdline.txt file and change root=/dev/mmcblk0p2 to root=/dev/mmcblk0p6
  • Continue the booting

Not the answer you're looking for? Browse other questions tagged or ask your own question.