I run the commands

/opt/vc/bin/tvservice -o<br>
/opt/vc/bin/tvservice -c "PAL 4:3"

and the screen changes from the default "no signal" screen to a black screen. This shows me that the Raspberry Pi is sending a signal but it is just a black screen. I am using a Raspberry Pi B+ running on raspbian. I am using the composite port. How can I fix this?

  • Does your Pi boot to GUI or command line? What are you using as your display? Is their anything (including a cable connected to the HDMI port? Oct 15 '14 at 1:52
  • It boots into command line, I am using a tv, there is nothing connected to the hdmi port.
    – Kyriazis
    Oct 15 '14 at 1:55
  • Is it an led/lcd tv with overscan or an old crt? If and lcd screen do you have overscan enabled on the tv or raspiconfig? if Overscan is enabled you may not be able to see the edge of the screen and the commmand prompt is there you just can't see it. You can try booting and after a minute try typing (50 chars or so should help diagnose the problemm). Oct 15 '14 at 2:09
  • The 50 chars doesn't show up. Also, I tried getting into the desktop with startx, thinking the background would change to white (desktop background) but it didn't.
    – Kyriazis
    Oct 15 '14 at 21:26

This seems to be a problem with the noob release - previous versions would default to the composite video if nothing was connected to the HDMI port.

To correct this do the following:

  1. Connect your keyboard and TV to the Pi.
  2. Insert your SD card.
  3. Power on the TV.
  4. Power up the Pi and hold down the SHIFT key, until the green LED stops flickering This will force the Pi into recovery mode).
  5. If the screen is still blank try pressing the 1, 2 3, 4 keys in succession (one of these will direct the output to the composite video port. You should now have the noobs menu on the screen.
  6. If you haven't already done so choose an OS to install, and reboot. You may need to repeat the above to get back to this menu and continue to the next step.
  7. Once you have an OS installed you will need to edit the config file (there is a link on the noobs menu) to select your TV type. Look for this line:


    remove the leading # and change the number at the end to one of the following:

    based on your TV type

    sdtv_mode=0 # Normal NTSC
    sdtv_mode=1 # Japanese version of NTSC – no pedestal
    sdtv_mode=2 # Normal PAL
    sdtv_mode=3 # Brazilian version of PAL – 525/60 rather than 625/50, different subcarrier

  8. Add the following line to the file:


  9. Make sure that the following line


    is commented out (has a # at the start of the line).

10.Press the TAB key.

  1. Click OK

  2. Then hit the ESC key and let the Pi reboot.

Reference and more details can be found here.

  • i have Raspberry pi3 , but the above steps are not working., i can see the display on HDMI but on on Composit
    – N.K
    May 14 '16 at 3:15
  • @N.K If you have a NEW question, please ask it by clicking the [Ask Question] (raspberrypi.stackexchange.com/questions/ask) button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. May 14 '16 at 3:42
  • Thats not a new question, i am saying that the above steps are not working for me...
    – N.K
    May 20 '16 at 3:16
  • @N.K then start a new question and reference this question and add that this answer does not work for you. May 20 '16 at 10:00
  • -1 I'm afraid that didn't work!
    – xXliolauXx
    Jun 2 '16 at 15:38

Edit the config.txt file

The config.txt file is located in /boot directory.

sudo nano /boot/config.txt

Go to following line, and place # at start, if already not there:


This will make the line like this:


Then save the file (Ctrl+o) and exit (Ctrl+x)

RPi - Edit config.txt file in by nano

  • Thank you! The question has already been answered, but this is another excellent solution!
    – Kyriazis
    Mar 23 '15 at 17:25

In case someone is stumbling across a just flickering screen [not blue(no signal), not black(consistent signal)]: Double check your connection!

Just found out that Raspberry decided to not stick to commercial 3.5mm 4pin standard. Thought I can use a regular 3.5mm 4pin cable (with composite video), but u can not.

They inverted GND and Video pin:

Sleeve - Composite video (NORMALLY THIS IS GND)
Ring 2 - Ground
Ring 1 - Audio-Right
Tip - Audio-Left

Check out the Schematics here.

  • 1
    Which of the 3 incompatible "standards" did they not stick to?
    – Milliways
    Jul 15 at 1:43
  • Excuse my lack of knowledge, but why in the hell are there 3 different ways to design a pin mapping for such a simple cable? The one I am familiar with applies both to my Samsung tv and my wireless FPV setup. Such "problems" can be quite frustrating, especially if you try out other solutions that are doomed to be unsuccessful.
    – n0sr3v
    Jul 15 at 6:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.