I have a formatted 8gb sd card (7.1gb available) and I've tried multiple times to install the roughly 4gb in size RetroPie disk image.

Each time I do, it says I have 55.9mb left and says it becomes FAT format when I previously formatted it to NTFS.

Has anyone else had this problem?

  • 1
    Did you re-size the OS partition after the install? many images are intentionally small such that they can fit on say a 4gb sd card, but then have a configuration to quickly re-size themselves to whichever size they were installed on. Also, linux tends to use multiple partitions, but the basic windows will only display the first partition. – user2813274 Oct 20 '14 at 19:58
  • Hmm could be the case, I'll have a look when I get home from work. Thanks for the heads up! – SaturnsEye Oct 21 '14 at 7:21
  • The 55mb looks like a boot partition the main part of the disk will be on the other partition, depending on distro and install method. – rob Oct 21 '14 at 7:58
  • @rob yea I'll have to look into that. It's weird because not long ago I set up my brother Pi and I'm sure I used the exact same disk image and installed it all the same and never came across the problem.. – SaturnsEye Oct 21 '14 at 8:15
  • 1
    The RetroPi image is actually a real image from a disk. Including partition table. And filesystems. Hence formatting it to NTFS prior to flashing has no effect at all since the image brings along its own filesystem. EDIT: Old question is old. Y U answer, jbutewicz? – user236012 Feb 20 '15 at 14:40

This is always the case when installing RetroPie from the image. You have to expand the filesystem to make all of the space available to you. Go to the command line. If in Emulation Station then press F4 to get to the command line. At the command line type:

sudo raspi-config

and press Enter. This will display the configuration tool. Select option 1. Expand the Filesystem an press Enter.

That's all you have to do. The full space will be available for you to use now.

  • Works like a charm! – Guus Dec 13 '15 at 15:58

Using raspi-config expand didn't work for me after several tries, had to do the following:

sudo resize2fs /dev/mmcblk0p2

This seemed to work as expected.

  • That only makes sense if you have already resized the partition somehow. – Dmitry Grigoryev Jan 10 '17 at 10:39

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.