1

I have installed XBMC on Raspbian Wheezy and configured LIRC to control XBMC with IR Remote. Everything works fine like right, left, up, down and other keys that I have configured except for Volume down. I don't know why volume down alone is not working.

I checked in IRW. It also indicates KEY_VOLUMEDOWN.

I find it strange that only volumedown alone is not working. Is there some kind of bug?

  • You should have a look at this anwser – Morgan Courbet Oct 21 '14 at 15:42
  • Thanks for pointing me to the post. But my mapping is configured properly and IRW shows all keys, like KEY_UP, KEY_VOLUMEDOWN. In my case sometimes if I restart volume down is working. – Logesh G Oct 22 '14 at 13:56
  • Well, so the problem doesn't occur everytime. And since irw outputs the volume down key, the problem seems to be in XBMC. I suggest to enable logs in XBMC. – Morgan Courbet Oct 22 '14 at 14:19
  • I saw people configuring F14 to Volume_Down in keyboard.xml. I did the same & yet I did not get it working. Finally I found out that since XBMC was started from irexec, xbmc was running as root. So I had to configure the keyboard.xml in root's home dir(/root/xbmc). I got it working now. :) Huh... – Logesh G Feb 13 '15 at 5:28
2

I saw people configuring F14 to Volume_Down in keyboard.xml. I did the same & yet I did not get it working. Finally I found out that since XBMC was started from irexec, xbmc was running as root. So I had to configure the keyboard.xml in root's home dir(/root/xbmc). I got it working now. :) Huh...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.