0

I've been looking at a number of different tutorials for sharing my attached external hard drive over my network, and can't seem to get any to work. Currently I have /home/pi accessible from my windows machine, but I can't seem to get anything else. When I plug in the external HD to the pi, its contents are available under /media/The Jolly Roger. I have tried putting the following in /etc/samba/smb.conf:

[share]
path = /media

however that doesn't make it available

In addition, when I type the command sudo chown -R pi:users /media/'The Jolly Roger' and hit enter it doesn't take it, it instead goes to a new line and then every time I hit an arrow key it outputs ^[[X. Not sure what this means.

I'm relatively inexperienced with Linux, so there might be something obvious that I am not aware of. Thanks.

What I'm looking at:

http://www.howtogeek.com/139433/how-to-turn-a-raspberry-pi-into-a-low-power-network-storage-device/

  • 1
    have you tried the chown command with the quotes around the whole path like this sudo chown -R pi:users "/media/The Jolly Roger" Also note you are sharing media but only chaining the subdirectory. You probably want to do this instead sudo chown -R pi:users /media. It would also help if you post the samba.conf – Steve Robillard Oct 26 '14 at 4:12
  • 1
    The ^[[X etc means the shell is expecting something else before it executes the command. Most likely seen with a missing closing quote. The resolution as @SteveRobillard notes is to ecase the entire path in double quotes. – rob Oct 27 '14 at 14:28
  • I've tried double quotes and it still does the same thing. – ahota Oct 28 '14 at 3:57
  • What happens if you rename the directory and remove the spaces (either use underscores, hyphens or run the words together with camel case). In Linux they often cause more problems than they solve. FYI if you don't include the @username we won't be notified of new comments. – Steve Robillard Oct 28 '14 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.