3

I need to disable the framebuffer running on /dev/fb0 via the bcm2708_fb kernel module (reason: some tool I use must run on /dev/fb0 and I need my small TFT to be just that - fb0). Disabling bcm2708_fb in the kernel leads to a few errors during kernel compilation which I like to forego.

I there a known way to
a) have bcm2708_fb in the kernel but
b) not load it, thus leaving /dev/fb0 unpopulated until I load my small TFT framebuffer driver?

According to the source of bcm2708_fb there's no parameters not to load the driver when compiled as a module, according to multiple sources I googled there's no way of not loading a compiled-in driver.

Any help would be highly appreciated.

2
  • I don't understand what you are doing but have a look at github.com/notro/fbtft
    – joan
    Nov 4, 2014 at 14:59
  • That's where I got the FBTFT driver from, of course. Please re-read my request: How do I disable a built-in driver that resides within the kernel itself and is not compiled as a module?
    – Christian
    Nov 4, 2014 at 15:15

2 Answers 2

0

You can set max_framebuffers=0 in config.txt to completely disable framebuffer devices.

To just disable the module, this answer plus looking at the bcm2708_fb code suggests that adding initcall_blacklist=bcm2708_fb_init to the kernel command line should do the trick, however I have not tested this.

Alternatively you could write a udev rule to make the default framebuffer appear as /dev/fb1 and your framebuffer driver appear as /dev/fb0, so that you can use both but your own one appears as /dev/fb0.

-1

You could use fbcp to mirror /dev/fb0 onto /dev/fb1.

See Github: notro/fbtft -Framebuffer mirroring.

1
  • 1
    If you could edit your answer to include a synopsis of the details from the link, then that would be great. Apr 8, 2016 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.