2

I have my R-Pi connected to a 15" monitor running 1024x768 resolution. Wierd thing is that I can't seem to make the image fill out the display. It's connected using HDMI.

I've tried setting disable_overscan=1 and mixing with the overscan_top/left/right/bottom values but nothing seems to make it any difference.

Right now I have framebuffer_width=1024, framebuffer_height=768 and disable_overscan=1 and the image is as the attached photo. It's correct just not all the way to the right/left edges.

enter image description here

Can anyone please tell me where to keep looking/troubleshoot? Thanks

2

I assume you get similar when booting to the command prompt. I suggest you works there to get it right, as the GUI can cause additional issues.

It is probable that your monitor does not support the resolution the Pi expects. You can troubleshoot this to find what modes it supports.

Enter the following command to give a list of CEA supported modes

/opt/vc/bin/tvservice -m CEA

Enter the following command to give a list of DMT supported modes

/opt/vc/bin/tvservice -m DMT

Enter the following command to show your current state

/opt/vc/bin/tvservice -s

Look at http://elinux.org/RPiconfig#Video for more info.

If you still can't resolve it post the outputs of the above commands.

  • That did it. I was using the wrong combination of hdmi_group, hdmi_mode and sdtv_aspect (aspect was setting 16:9 but I needed 4:3 for the correct resolution). Thank you! – naboovalley Nov 7 '14 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.