3

since a few days I'm a proud owner of a RPi Model B+ and a 2,8" RPi-Display from Watterott. HDMI output works fine, I am using a preinstalled Raspbian that boots into desktop.

I followed this tutorial to set up the display. As soon as I get to Step 3: Activate Framebuffer, the displays's backlight turns on, but nothing more. con2fbmap 1 1 does absolutely nothing, FRAMEBUFFER=/dev/fb1 startx & lets the HDMI output disappear for a few seconds, and then returns with all programs closed.

Any ideas what could be the problem? Apparently I am a rather new to the linux world.

When I use rpi-fbcp (github.com/tasanakorn/rpi-fbcp) to simply mirror the HDMI output to the display, it works, so the hardware seems to be fine.

2

Are you exactly running con2fbmap 1 1 after the display drivers are loaded?

If the desktop runs on HDMI also with the Framebuffer set to fb1, then there is an option in /usr/share/X11/xorg.conf.d/99-fbturbo.conf. Look for the line Option "fbdev" "/dev/fb0" and remove/comment it. It is this issue: https://github.com/notro/fbtft/issues/63

  • Thanks for your reply! That partially solves to problem, after commenting out that line I can now put the screen on the rpi-display with FRAMEBUFFER=/dev/fb1 startx &. However, con2fbmap 1 1 still does nothing. I run it exactly after sudo modprobe fbtft dma and sudo modprobe fbtft_device name=rpi-display speed=32000000 rotate=270. – Timo Hausmann Nov 13 '14 at 19:19
  • I just got con2fbmap 1 1 to work! My fault was not to boot into console and I tried to run the command at the desktop terminal, whoops. – Timo Hausmann Nov 13 '14 at 21:58
  • Nice to hear that it is now working. I have also updated the documentation with more infos. – Andreas W. Nov 14 '14 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.