I have an Rasberry Pi B. I have copied Raspbian to SD card. I plugged RPI into TV and set it up. I enabled SSH at boot.

I rebooted, and took it to my laptop. I connected the laptop and Pi via Ethernet. I am using Ubuntu on laptop. I connect it, and I get a little spinning orb in the top right corner showing that it's connecting.

It never connects though. I always get a Disconnected popup telling me that it failed to connect via wire.

What am I doing wrong?

  • The Pi, by default, will be expecting to be given an IP address. Are you running a DHCP server on your laptop?
    – joan
    Nov 9, 2014 at 20:26
  • if you can see the output on the Pi run "ifconfig -a" then run the same on the laptop (Mac/Linux) or "ipconfig /all" (Windows) and make sure the ip address are in the same range, added them to your question if you are unsure.
    – rob
    Nov 10, 2014 at 10:12

2 Answers 2


I had this problem too. The pi is looking for a DHCP server, but when you plug it straight into your laptop it won't be able to find one by default. What I did is (on Windows only) I went to network settings > change adapter settings > my WIFI adapter > properties > sharing and check the box marked "Allow other network users to connect through this computer's internet connect" and finally select your ETHERNET adapter from the drop down. Then reboot the pi or reconnect it and if all goes well it should connect. Then you can use ifconfig (on the pi) or a tool like nmap (on your laptop) to find it's address and SSH into it.


The Raspberry pi and your laptop need to be on the same subnet. Therefore go to your internet settings on your mac and set a DHCP with manual address, e.g. Then on your RPi, connect it to a screen and keyboard and give it a manual address such as When the RPi has booted, type in

sudo nano /etc/network/interfaces

Now look for the eth0 line which corresponds to the Raspberry pi ethernet port and edit the file to look similar to this:

iface eth0 inet static

Once the file has been updated, use ctrl x to save and exit. Now reboot the pi and test if the connection works by pinging the laptop: ping 192.168.10.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.