1

Problem

The /boot/config.txt file is being ignored when the Raspberry Pi boots up. As such, overscan and overclocking settings are not taking effect.

What I've tried

Some reported that the line breaks may be the cause. I checked that there are no Windows-style line-breaks or carriage-returns in the file. All seems to be in order. I even let raspi-config generate the file to be sure. And to be extra sure, I also tried putting all the options in a single line, as some suggested on other threads.

Tried updating the firmware by doing:

apt-get update, apt-get upgrade and rpi-update.

Everything is at the latest. Using cpufreq-info showed that overclocking is not taking effect, even with force_turbo=1, so the file is definitely being disregarding at boot.

Technical Info

  • Raspberry Pi model: B+
  • Image: Raspbian Debian Wheezy (from raspberrypi.org)
  • Firmware version: 3.12.28+

Edit #1

After tirelessly digging deeper, I've found other config.txt files on the Pi. In the /media directory, which contains the following 4 subdirectories:

  • /media/boot
  • /media/boot_
  • /media/boot__
  • /media/boot___

I edited the config.txt file in each of these four directories with different settings to see which one is being used, and it turned out to be the one in the media/boot___ directory (last one).

So now the question is, is this normal? If not, is there any way to clean this up so that I have only one /media/boot directory?

Also, the other 3 directories give "Permission denied" if I try to cd into them. I can if I'm in su, but otherwise unable to do so.

Edit #2

It's also worth mentioning that raspi-config modifies the file located at /boot/config.txt rather than the proper /media/boot___/config.txt

  • Could you append an ls -l of the /boot directory and the contents of your config.txt file to your post? – joan Nov 10 '14 at 16:22
  • Check if the boot partition is mounted (/dev/mmcblk0p1) and if you're editing the right file. – user236012 Nov 10 '14 at 16:30
  • @user236012 Thanks for that! Didn't think to look for that. See my updated question. – Mecha Nov 10 '14 at 16:34
  • Where does this /media directory come from? Are you editing the SD card in another machine, not on the Raspberry Pi itself? – joan Nov 10 '14 at 17:00
  • No, everything I add/modify is done directly to the Pi itself, either via SSH or VNC. – Mecha Nov 10 '14 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.