Currently whenever I play a video omxplayer starts playing it. But I cannot actually see the video being played.
For example I run the following command to play it.

omxplayer video.mp4
How do I make it work?

2 Answers 2


All hardware accelerated players go directly to the video hardware (overlay). You can only view them on a monitor connected directly to the Pi.


To enable video output while using VNC you will need to do the following on older versions of VNC server on the Rasperry Pi.

Open VNC Server>Options>Troubleshooting. Then make sure "enable experimental direct capture mode is checked.

You should now be able to view videos over vnc.

You may also want to consider doing the following but it is not necessary. https://github.com/RealVNC/raspi-preview#optimizing-vnc-viewer-for-the-raspberry-pi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.