1

The device is being picked up by my pi. I also checked to make sure the 8192cu module is being loaded by the kernel as well. But I simply cannot connect to my wifi. I have tried multiple methods. I have used the provided wifi_config gui. I get the following error message.

Authentication to the driver failed

So I tried to manually go and configure my /etc/network/interfaces file using the following options

auto wlan0
iface wlan0 inet dhcp
         wpa-ssid = "foo"
         wpa-psk = "bar"

I have also tried using wicd-curses. All three methods are finding the network just fine, however they all seem to be running issues when trying to connect.

1

To test this in a basic way, first stop the networking daemon:

service networking stop

Edit /etc/wpa_supplicant/wpa_supplicant.conf; you need root privileges. There should be only one entry for network, like this:

network={
    ssid="yourSSID"
    psk="yourPassPhrase"
}

And other than the first two lines (not shown), that's all you need in that file. If it doesn't look like that, create a backup copy of the file and change it so it does. You've already confirmed the kernel 8192cu module is loaded. Apparently wlan0 is the interface name, double check that with ip link. If there's a wlan0, we're good.

wpa_supplicant -d -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0

Give it about 10-15s. That will run in the foreground so you will now need to open a second terminal and run:

dhclient -v wlan0

If you get a lease, congratulations, everything works. Confirm with ip link which should show an IP address associated with wlan0.

If you can't get this to work -- e.g. wpa_supplicant fails -- it is probably a driver issue. Have a look at this list of wifi adapters known to work/not work on the pi and see if yours is there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.