1

My raspberry is connected to my laptop directly. I cannot ping anything from pi not even gateway. My laptops IP is 192.168.137.1. I am SSh ing to PI

ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:75:03:79
          inet addr:192.168.137.10  Bcast:192.168.137.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:229 errors:0 dropped:0 overruns:0 frame:0
          TX packets:315 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:17200 (16.7 KiB)  TX bytes:43185 (42.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

My /etc/network/interfaces is

auto eth0
iface eth0 inet static
address 192.168.137.10
network 192.168.137.0
netmask 255.255.255.0
broadcast 192.168.137.255
gateway 192.168.137.1

route -n gives

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.137.1   0.0.0.0         UG    0      0        0 eth0
192.168.137.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
1
  • What is the gateway of your laptop? – cutrightjm Nov 16 '14 at 6:40
1

Well assuming you are successfully ssh-ing to the RPI module. The only (few) reasons why pinging is unsuccessful is because you haven't turned off either windows firewall or any additional firewall that you may have, as they usually filter fragmented traffic I.e. pings Also look for a traceroute command for the laptop and Linux command equivalent it might shed some light on the connectivity you may have.

1

Are you re-using the IP address? I had the same issue where I moved pi-hole to another server but gave it the same IP address. The problem turned out to be that my router had cached the IP / mac address pair and was returning packets to the wrong MAC address.

Doing an "arp -d -a" on my router cleared the cache and fixed my issue.

3
  • Please use the comments area for comments! – MatsK Jan 9 '19 at 18:36
  • In general a good answer but the OP can connect with ssh so there is no addressing problem. TCP works. It seems to be specific for ICMP (ping). – Ingo Jan 9 '19 at 20:20
  • This was long time ago. I don't remember how i fixed it or if it was fixed at all. Please don't waste your time in this. I'll try to close this question. – Srijan Kumar Sharma Jan 10 '19 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.