1

I am trying to get the new Gutenprint 5.2.10 driver to work with CUPS 2.0.0 in my Rasberry Pi, using Raspbian8. I'm still kind of new to the Linux environment so please bear with me if I use the wrong terms.

I installed CUPS 1.5.3 using sudo apt-get install cups unknowingly that it would install an older version. So I subsequently removed it through package manager and installed CUPS 2.0.0.

However, removing CUPS 1.5.3 did not remove the older Gutenprint 5.2.9 driver. Even after removing the Gutenprint 5.2.9 package files in package manager, leaving only Gutenprint 5.2.10 package files, CUPS 2.0.0 is still not refereing the package files.

I know this because I do not see the printer model in the list in CUPS browser interface when adding a new printer.

I did however, manage to get it working in my Ubuntu machine.

Can anyone point me in the right direction to get CUPS to use Gutenprint 5.2.10?

  • Which version of Raspbian are you using? cat /etc/os-release. On jessie the driver is 5.2.10. printer-driver-gutenprint (5.2.10-3+b2 Raspbian:testing [armhf]) – joan Nov 15 '14 at 18:00
  • @joan Raspbian GNU/Linux 7 (wheezy) – ali Nov 16 '14 at 15:19
  • You could update to jessie. That would give you 5.2.10. However jessie is the testing distribution so other things might be broken (wheezy is the current stable distribution). – joan Nov 16 '14 at 15:38
  • @joan ah alright. so there is no way to configure CUPS manually in wheezy to use gutenprint 5.2.10? – ali Nov 16 '14 at 15:39
  • 1
    I don't know. I haven't tried. It would depend on how many packages would need to be updated to support 5.2.10. If something like a core library needs to be upgraded it could break other packages within wheezy. The latest version of CUPS supported by Debian is 1.7.5-7. CUPS 2.0.0 seems to be bleeding edge. – joan Nov 16 '14 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.