2

I got a RPi scientific kit from CrazyPi.com. The kit came thru nicely, and upon following the instructions from various forums, I was able to do the following:

  1. Connect the RPi to a VGA display using the HDMI-VGA converter and boot into NOOBS.

  2. Install Raspbian, then got the internet to work, camera worked, installed packages etc.

  3. USB hub worked with keyboard and mouse.

  4. When I tried to get the video on the 4.3" TFT (also part of the kit), using the RCA composite cable, no success.

I have done a few things as mentioned in posts etc.

  1. When in NOOBS, and both HDMI and RCA cable connected, try changing the display from HDMI, to safe-HDMI to RCA to NTSCby pressing 1,2,3,4 respectively, however, the keypresses 1, and 2 changed modes, 3 and 4 were un-responsive.

  2. Upon booting, tried changing the file ~/boot/config.txt and commented the line "hdmi_force_hotplug=1", which forces HDMI out, then restart without HDMI. In this case the behavior is rather surprising. The RPi doesnt boot at all without the HDMI cable, which is evident from the consistent green-light and ethernet and USB hub not lighting up.

The TFT has three outputs, one yellow, one white and one red. Yellow and white match to the RCA composite cable and red is used for powering the TFT, with an adapter. It works fine as it shows the crazypi background image on powering.

Another reply from crazypi support asked me to "activate RCA out in the configuration of Raspbian OS".

What am i missing here ?

EDIT: Upon further tinkering, I found that dis-connecting the RCA cable and HDMI, the Pi boots, as expected. So the problem seems to be in RCA cable/TFT, how can I debug this further ?

0

You can have HDMI output or you can have composite video output.

You can not have both at the same time.

http://www.raspberrypi.org/forums/viewtopic.php?f=63&t=4034&p=53117

  • I knw how to get HDMI, I want to get composite output. I just tried with HDMI and without, both ways, I didnt get the output on TFT. The attempt two described above has HDMI disconnected, and the RPi doesnt boot. – Chintan Pathak Nov 18 '14 at 17:05
  • Is this a B or a B+? The B+ has a different AV socket. The Pi not booting seems to be a separate issue. – joan Nov 18 '14 at 17:16
  • this is a B+. Pi boots with HDMI, so the Pi is fine I guess, but doesnt boot without, I am using the provided rated power supply 5V-2Amp. – Chintan Pathak Nov 19 '14 at 4:22
  • As I said you have two issues. The apparent non-boot is the one to sort first. Is the Pi networked? Have you tried pinging raspberrypi ? Also look through raspberrypi.org/forums/viewtopic.php?p=580198#p580198 and check your A/V jack. – joan Nov 19 '14 at 7:51
0

Pi wasn't booting and hence there was no display on the TFT.

This was only happening when I connected the TFT, and not the HDMI.

Issue was accidently resolved when, I tried powering the Pi thru my PCs USB port, and everything worked fine.

So, the problem was with the provided power supply, which either wasn't delivering the promised 2A, or 2A isnt sufficient for the setup. (Although the FAQs about B+ mention that 2A would rarely be needed and I am using externally powered USB hub)

I would be trying now with 5V, 5A adapter, (as I also plan on using the GPIO pins, which have extra current requirement) although it works with my PC USB port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.