2

I have a problem with my raspberry. I have installed Raspbian, used the command startx, and it worked.

After that I configured it so I can access it over network. I used PuTTY to remotely access it and when I use the command startx, it freezes at FATAL: Module g2d_23 not found. until I press Ctrl+C or Ctrl+Z.

  • 1
    You are trying to startx from a remote shell, but where would you like the desktop to appear? On a monitor connected to the pi, or on the remote system? – goldilocks Nov 25 '14 at 21:15
  • On the remote system – Silviu Dragomir Nov 25 '14 at 21:25
2

If you want to use the GUI on a remote machine you can use VNC. tightvncserver is available for the Pi. There are hundreds of tutorials on this.

You need VNC on your computer, again there are lots of options.

| improve this answer | |
0

I experience the same problem. This error is not something blocking use of startx. When you use Putty (ssh client) , you won't see any X server output no matter how well your xserver is configured. after you startx use an Remote Desktop Protocol to connect to your Pi and get access to X.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.