1

I have a Raspberry Pi B+ and a external 2.5" Seagate Backup Plus connected via USB (no external power source). Since the latest update, my Pi can no longer automount the drives that are plugged in USB ports. When I manually mount the HDD, it doing well in idle mode but when I began to read and write data to it (run a torrent client) the drive keeps power up and down (ie the LED is flashing about 1 time per second and I can feel the HDD spinning up and stop). I also tried to mount the HDD on boot using ftab but it useless.

Can anybody help me with this problem?

2

Have you tried using a powered external USB hub? It is possible (likely?) that the RPi is unable to supply all of the power needed by the external HDD and as a result you're getting unpredictable/erratic behavior from the hardware.

  • ... but how could this have changed by a OS update? – Ghanima Nov 28 '14 at 14:49
2

The small 2.5" drives I have seem to work OK powered from USB ports.

Have you enabled the B+ high power USB mode? This lets 1200mA flow to the USB rather than 600mA.

To enable high power mode (only available on the A+/B+) write 1 to gpio 47.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.