2

I've Googled and searched SE and found issues like this, but mine is a different problem than what I've found. I'm setting up a few Raspberry Pi kiosks to be digital signs. The Pis are running Chromium in kiosk mode and, after a reboot, typically boot to a blank screen. However the Pi itself is accessible via SSH and anything else I care to try. So there seems to be something up with the display that I'm totally missing.

I've made the following changes and tweaks to the Pis:

  • LXDE autostart runs a command on login that starts Chromium and points it at the right place. The command is chromium --noerrdialogs --kiosk SERVERURL
  • I've added a line to /etc/lightdm/lightdm.conf to disable screen blanking. I've tried other methods and this is the only one that works. The line itself goes under [SeatDefaults] and is xserver-command=X -s 0 dpms
  • I've added a line to /boot/config.txt that rotates the display 270 degrees so the monitors can be vertical rather than horizontal. The line is display_rotate=3

Finally, the Pi is set to login to the GUI on boot. When it works, it's working flawlessly. However the booting to blank screen thing is driving me nuts because I just can't seem to track it down. Any ideas? And thanks so much!

  • are there any errors listed if you run dmesg? have you tried adding a sleep so the start of chromium is delayed. Are these model A, B, A+,B+ ? – rob Dec 8 '14 at 16:02
  • I don't see anything amiss in dmesg and this is happening on multiple models of Pi. I've seen it on the B+ mostly, since that's what I'm using the most of. However I've got a Model A here too that does the same thing. As an aside, I've done all the updates for these before I even started. So I don't think it's an old software issue. However, I'll give that sleep command a try and see if that helps! Thanks! – Bibrarian Dec 8 '14 at 16:22
  • what about the sleep? – rob Dec 8 '14 at 16:24
  • Do you have a monitor you can try w/ the composite jack to see if that's the issue? Do you have hdmi_force_hotplug=1 set/uncommented in config.txt? – goldilocks Dec 8 '14 at 16:48
  • Okay the sleep didn't work, but I discovered something even weirder. I was trying to get something, anything, to show up on the display so I hit CTRL ALT F1 through F7, just kind of working my way up the F keys. The display came up. It came up with Chromium doing what it's supposed to do... like it was in the background or something. I'm starting to think it has to do with the xserver-command or possibly the display_rotate. Digging into it now. – Bibrarian Dec 8 '14 at 16:54
1

Presumably lightdm is configured to use the same virtual terminal (aka. vt, there are 6 or 8 of them accessible via ctrl-alt-F[n]) every time. If so, you just need to figure out which one, and you can then use:

chvt [n]

Where [n] is the vt number (these are the same as the tty[n] numbers). Of course, where and when to do this may be awkward.

You might also (or instead) look at something in lightdm.conf which influences this:

# minimum-vt = First VT to run displays on

The actual setting is under [LightDM] and it's commented out, but if that indicates the default, it's 7 (as you say, commonly so). You might as well use 1:

minimum-vt = 1

Hopefully this gives predicatable results.

Additionally, since you've already provided an xserver-command=X command, you can add, e.g., vt1 to that, i.e., xserver-command=X vt1 .....

0

Okay, so it turns out that the xserver-command=X -s 0 dpms code in my lightdm.conf file was probably the blame for everything. I don't know if it's an issue with the (admittedly older) monitors I'm using. Once I removed it, the Pis always booted to a proper LXDE Raspbian screen. Of course, they also would go blank after a while.

The answer is one of the dumber hacks I've ever seen.

While in a terminal, install the xscreensaver package:

sudo apt-get install xscreensaver

Let it roll through the install and then bring it up on the LXDE desktop. Then disable everything. Disable the screensaver, the power management features, anything that might make the screen blank out after a given time. For the most part, you can uncheck everything.

I've got four Pi kiosk demos here at my desk and none of them have gone blank in the last three days.

Thank you so much for all your ideas and help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.