5

I just got my A+. It does not have an Ethernet port.

I'm having trouble getting a network connection so I could to ssh into it.

Here is what I did so far:

  1. Inserted the pre-installed NOOBS SD card
  2. When first powered on, the LEDs were Green and Red
  3. The LEDs after a power-cycle came up just Red
  4. Inserted a USB WiFi dongle

Am I missing anything? What is the next thing that is supposed to happen?

  • I guess my problem is that NOOBS does not start-up with netwrok and sshd running. I'll need to connect an hdmi monitor and a keyboard and go thru the setup. – Aleksandr Levchuk Dec 11 '14 at 5:54
3

Connect an HDMI and then power it on.

Navigate to your /etc/network/interfaces file and enter your wpa-ssid (or whatever wireless encryption you use) and your wpa-psk password. then sudo shutdown -h now

Insert your wifi dongle then power it on.

an example of an ssid and -psk

wpa-ssid "iLoveLamp"
wpa-psk "MyPassword"
  • @Aleksandr Levchuk - did you get it to work? – 1'' Dec 12 '14 at 3:37
  • i got it to work thru a USB to Ethernet adapter, but I first needed to connect thru HDMI and keyboard. As soon as I connected the USB, eth0 showed up in ifconfig. Then I ran dhclinet eth0 (i also enabled "Internet Sharing" on my Mac laptop). Now in ifconfing shows a working IP address :) – Aleksandr Levchuk Dec 15 '14 at 5:57
2

I got my wireless adapter to work by following the instructions at the following blog:

Automatically connect a Raspberry Pi to a Wifi network

On raspbian using a usb keyboard with the pi attached to an hdmi tv I edited the following file

/etc/wpa_supplicant/wpa_supplicant.conf

use the following command to edit it from the command line

sudo vi /etc/wpa_supplicant/wpa_supplicant.conf

press a to enter append mode, then add the following to the end of the file

network={
ssid="YOUR_NETWORK_NAME"
psk="YOUR_NETWORK_PASSWORD"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

then shutdown

sudo shutdown -h now

after that plug in the adapter and start up

  • to save and quit from vi press : then enter wq – user24541 Apr 23 '15 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.