1

I'm trying to run Midori on my Raspberry Pi over SSH and I would like it to appear on the screen of my PC. (The PC runs Xubuntu.) I tried to follow instructions like this, but I still can't see the browser appearing on my screen.

  • I do use ssh -X
  • X11Forwarding yes is set on the Raspberry
  • xauth is installed on the Raspberry
  • I even tried to set X11UseLocalhost no on the device

And then if I run DISPLAY=:0 midori I get debug messages like

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-bar-popup-delay after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-can-change-accels after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popup-delay after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popdown-delay after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-label-select-on-focus after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-images after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-button-images after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-scrolled-window-placement after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-entry-select-on-focus after class was initialised

(midori:11871): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-entry-password-hint-timeout after class was initialised

Which I guess is OK, but then nothing else happens.

What did I do wrong?

5

You have to use Upper-case X not a lower case x

ssh -X

to enable X11 tunneling over SSH.

Also on host you are connecting from do:

export DISPLAY=<ip of your host from where you ssh from>:0

xhost +

to allow incoming X11 connection from any host

  • Thanks, I didn't know about the xhost thing. (The -x was just a typo here, I used -X in the terminal.) However I'm not any closer, I still don't see the GUI on the PC. – ytg Dec 15 '14 at 19:57
  • @ytg I amended my answer. make sure to export the display as well. SSH -X will do it for you also but I added JIC. – Chetan Bhargava Dec 15 '14 at 20:06
  • apparently something needs to listen on the port 6000. what should that be? – ytg Dec 15 '14 at 20:37
  • meanwhile I got aware of question like this askubuntu.com/questions/34657/… but I don't seem to have gdm on my PC – ytg Dec 15 '14 at 20:43
  • @ytg Here are my results. After I hit enter after lxterminal command, I get a lxterminal. Laptop is Linux laptop (xserver already running). Host berry is raspberry pi. – Chetan Bhargava Dec 17 '14 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.