I can't connect to my Raspbery Pi over SSH any more. The last lines that appear on booting are:

[ ok ] Starting OpenBSD Secure Shell server: sshd.
Error opening '/dev/input/event*': No such file or directory

(btw: what is /dev/input/event*?)

But when I try to connect to my Raspberry Pi, I get this:

$ ssh user@raspberrypi
ssh: connect to host raspberrypi port 22: Connection refused

I found out that there is a problem with the SSH Daemon. ps aux |grep sshd does not list it as a process. Once I start it manually


SSH works well and I can connect with the command above. But soon as I reboot and try it again, I get the same error message.

I already tried to reinstall the openssh-server and then reinstall it. That didn't help. Does someone have a solution?

  • 1
    is anything plugged into the Pi like a usb keyboard/mouse? if so try unplugging it/them before continuing.
    – rob
    Dec 18 '14 at 13:34
  • 1
    That was it. I unplugged the keyboard, restarted the Pi and it worked. Unbelievable... Dec 30 '14 at 19:49

/dev/input/event* is what it sounds like; a place for applications to receive input events (like a mouse click). As @rob noted the USB interface on the raspberrypi is somewhat unstable so not using it (or using a power isolated powered hub) are good first steps to otherwise inexplicable behavior.


To start sshd on boot, type :

sudo update-rc.d ssh defaults

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.