2

I am having a problem with FreeBSD, wherein I cannot get the text to be constrained within the area of a TV (composite). I have been using framebuffer_height and framebuffer_width in /boot/msdos/config.txt to get the right size but overscan_left, _right, etc. does not seem to be consistent. The size of the TV screen is approx. 11.5 wide x 8.5 high (inches). There are no real controls on the TV for the size of the viewing area as far as I can tell. The TV is manufactured in 1985, it is a Montgomery Ward TV.

Everything else with this FreeBSD-10.1-RELEASE-arm-armv6-RPI-B.img image seems to work fine. It seems with this image I cannot extract the ports tree but I had done that earlier with another image.

I have also tried using a config.txt generated from a debian system on the same TV, which set the framebuffer at 720x480 and the overscan settings all at 16, the only other thing in the file was disable_overscan=0... that was not commented out.

0

I don't know FreeBSD but I used the following to calibrate my display on Raspbian

https://raspberrypi.stackexchange.com/a/23104/8697

  • The script referenced looks to be a useful tool although I don't think it will work on FreeBSD. – eh-five Dec 19 '14 at 6:22
  • @eh-five overscan.c is actually the meat of that; it looks to be POSIX and should at least compile on FreeBSD. It's all just about the creation of a dev node and an ioctl() call -- which may or may not be linux specific, but if you know someone else running FreeBSD with a good grasp of system programming they might get a good clue from that. The script would probably work too (for creating the dev node, etc.) except it uses whiptail which is a bit of an oddity. However, the script itself is not strictly necessary. – goldilocks Dec 19 '14 at 18:21
  • Well, the problem really seems to be that I get no response from using the overscan settings, rather I get a change but not really predictable. The screen will be garbled in the initial stages with some settings although when I get to the login prompt it will be clear. – eh-five Dec 20 '14 at 6:03
  • I think the problem is that the settings are rather unusual. I found trying to do them manually didn't produce the results I wanted (and it was SLOOW). If you can't get this to work on FreeBSD, you could try on Raspbian and copy settings. Have you set sdtv_mode sdtv_aspect – Milliways Dec 20 '14 at 6:10
  • I agree, many layers of interpretation it seems. Of the video information. I have tried sdtv settings, the most success I had was with solely framebuffer settings. I was thinking that I should take the settings from a raspi-config generated config.txt too. @miliways, thanks – eh-five Dec 20 '14 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.