1

I am fairly new to Raspberry Pi. I wanted to make an Apache server with my Pi and I was trying to give it a static ip. But anytime I start up wpa_gui (or try to do anything with it for that matter), the program yells at me Could not get status from wpa_supplicant. My /etc/network/interfaces file looks like so:

pi@raspberrypi ~ $ sudo cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
address 192.168.1.200
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 8.8.8.8 8.8.4.4

I do have a wirless adapter connected although wpa_gui does not see it. But we can obviously see that linux sees it because:

pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 005: ID 046d:c509 Logitech, Inc. Cordless Keyboard & Mouse

I will note, however, /var/run/wpa_supplicant/ doesn't exist. If any of you know how to fix this, I would love to hear.

1

First, it you have error message like Could not get status from wpa_supplicant this obviously means that there's a problem with wpa_supplicant. Make sure you have it installed withdpkg -s wpasupplicant. If not, install it with sudo aptitude install wpasupplicant

If this fails to fix the problem, read on.

I suppose that you are trying to connect to a WPA/WPA2 WiFi using wpa_gui.

It seems that your WiFi adapter uses "exotic" chipset, called rt2800usb. It seems thar Raspbian doesn't fully support it. This chipset probably needs additional steps to enable which are described here. After enabling the adapter you may define the WPA/WPA2 ESSID and pass in /etc/network/interfces as described here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.