1

I have been trying to give my raspberry pi b+ running raspbian some wifi connectivity. So I bought this Comfast Wifi adapter WU810n chipset http://www.amazon.in/Comfast-CF-WU810N-V2-0-802-11b-Wireless/dp/B00MAC7H3O .

But I am unable to set it up. I have tried many method editing the /etc/networks/interfaces file and also the wpa_supplicant.conf files. But it still doesn't recognize it.

When I do 'lsusb' it shows "Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp." and not the full name of the chipset like it showed in the blogs i referred.

And when I do " sudo ifup wlan0" it returns an error "

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start

run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1

Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

wpa_supplicant: /sbin/wpa_cli daemon failed to start

run-parts: /etc/network/if-up.d/wpasupplicant exited with return code 1 "

And when I do "ifconfig" it doesn't show wlan0 it only shows eth0 and lo.

Thank you in advance. :)

  • Apparently that's a Realtek 8188EUS chip. There is a driver for it, but it is not included in the stock kernel. Can you cross-compile? – goldilocks Dec 23 '14 at 16:21
  • No I don't know how to do that. If possible can you send me a link or something to get it working. – user3112359 Dec 23 '14 at 17:23
0

Although that adapter was listed here as working out of the box on raspbian, evidently newer versions use a different chipset, as observed here, that is not included with current raspbian kernels.

It can be compiled, but since this is currently a "staging" driver there is no guarantee that it will then work. Doing so may require you compile the kernel as well, which on the pi takes hours. It can be done quicker on a normal PC ("cross compiling"), but this takes a bit of know how. There are various tutorials and how-to's around if you search, but I do not recommend this if you have not compiled a kernel normally to start with, or have some familiarity with compiling from source.

In short, you are potentially looking at a lot of time and frustration with no promise of success (4 or even 8 hours would be lucky, now think of having to just give up after 20, or 30...). Unless you are stranded somewhere, it would be much simpler to just dish out $15 on an adapter that is more widely (and recently) recognized to work on the pi.

  • 1
    I found a solution here! raspberrypi.org/forums/viewtopic.php?f=28&t=62371 But I would really like to know which Wifi adapter works directly out of the box. – user3112359 Dec 24 '14 at 11:24
  • That's truly nice someone did that. WRT to which ones work, the list from the first paragraph probably is mostly accurate. The way to double check is to find out what the chipset is, then check around online about that too. If you download the kernel source, you can also grep through the drivers/ directory with the chipset (e.g. grep -R 8188EUS drivers/) to see if it is mentioned -- if a driver is meant to explicitly support something, it will be described briefly in the source code. – goldilocks Dec 24 '14 at 19:44
  • Thanks for the link @user3112359. In addition to installing the driver at the link above, launching wpa_gui from the terminal made the rest of the setup (of wpa_supplicant) really easy for me. – koushik Jun 18 '15 at 19:23
1

Here is a simple fix I've used on my Raspberry Pi Model B in a case where the Comfast WU810n was not detected on the Raspbian OS:

  • Connect Pi to Internet using Ethernet or other Dongle that works
  • type:
    apt-get update
  • type:
    apt-get install firmware-realtek

That's it, it will worked for me after a Reboot...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.