I'm having some trouble with my pi. I'm using ssh connection only - through cable but I bought WiFi USB adapter so I can also connect my pi from my tablet. Unfortunately when I reconfigured interfaces(in /etc/network/interfaces) and rebooted pi, I couldn't connect to it as usual - through cable but the led on my WiFi USB stick was blinking. Then I tried a lot of configurations but none of them worked properly :/

What I want to have: -static eth0 address -static wlan0 address -possibility to connect with SSH through both eth0 and wlan0

Here's my /etc/network/interfaces at the moment:

auto lo

iface lo inet loopback

iface eth0 inet static

address 192.168.137.85

netmask 255.255.255.0

gateway 192.168.137.1

allow-hotplug wlan0

iface wlan0 inet dhcp

wpa-ssid "MySSID"

wpa-psk "SuperSecretPassword"

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

And it's working for eth0 connection but not for wlan0. And led on my WiFi adapter isn't blinking even if I turn the GUI on, the program can't see this adapter - yes, drivers are installed, yes - when I check lsusb I can see it, yes - when I check lsmod I can see the module(used by 0)

Please help me, I'm a noob in RPi and don't know what to do :/

P.S. I'm running Raspbian

up vote 1 down vote accepted

You may eventually make your config work, but I suggest you start with the standard configuration. See https://raspberrypi.stackexchange.com/a/23373/8697 for an example.

You can if you REALLY need to set static IP addresses, but if you have a router use DHCP. If necessary reserve addresses in your router, but get wireless working with DHCP first.

  • Hm, I think that static IP for wlan0 is not necessary, But I need it for eth0 for sure. I'll try the idea from Your link Thanks for reply :) – urban07 Dec 26 '14 at 10:06
  • Wow, it seems to be working - I can connect with putty to eth0 SSH AND WiFi is working - thank You very much :D – urban07 Dec 26 '14 at 10:23
  • But unfortunately I can't connect to it with SSH client on my android device through WiFi. What should I do to fix it? (It says: "No route to host" - rpi is connected to my home network) – urban07 Dec 26 '14 at 10:24
  • Nevermind, after reconnecting everything is just fine. Thanks for help! – urban07 Dec 26 '14 at 10:30

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.