1

I'm have 2 XBee Radios and 2 Raspberry Pis. I have the 2 communicating with the XBee radios set to 9600 Baud on the TX and RX lines from the Raspberry Pi.

I recently bumped the XBee radio default Baud rate to 115200 and tried with the Pis. They could not communicate with the modules at all with only the baud rate change. I then used my FTDI cables to connect the XBee to the Pi and it worked fine with the 115200 baud rate.

Howcome the 115200 baud rate works just fine with the FTDI chip, but not the native TX and RX on the headers from the Pi? How can I fix this? Thanks!

This Doesn't Work

This Does Work

0

The Xbee is designed for baud rates of 250 kbit/s.

I have been using serial communications for over 50 years. The No. 1 rule for reliable communication, over any medium, is to use the LOWEST rate you actually NEED.

  • No. This claim is incorrect by a factor of more than ten. 115200 baud is .115 Mbps, but actually only about 80% of that is data that can passed on. – Chris Stratton Jan 26 '15 at 5:05
  • @ChrisStratton You are right. I don't know what I was thinking. The general comment is still true. – Milliways Jan 29 '15 at 3:58
0

The Pi's UART is quite happy running at 115200 bps (and probably ten or more times that rate).

Perhaps the wrong baud rate was selected?

0

Twist your data cables while running at 115200. The FTDI provides crosstalk protection not needed at 9600.

  • What do you mean by "twist your data cables"? – Peter Mortensen Jan 2 '16 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.