4

So I got a Raspberry Pi B+ and it worked very well. Some day something happened and the microSD was broken. I checked it using badblocks. Now I got a new microSD and wanted to rearrange my structure but the pi won't boot at all. Everytime I connect it with the power supply the green LED just blinks 2 times and thats it, constant red and no signal. I tested this with all cables besides the power supply disconnected and even switched the power supply several times. I really don't know what to do.

Is my pi broken?

  • 2 blinks is actually good; none would mean it can't read the card at all, and more than two would mean there's something wrong with firmware, etc. on the card. I have been confused this way before after thinking I fried it -- I presume you've tried this with a monitor plugged in? Is there no output at all? Make sure you have hdmi_force_hotplug=1 in config.txt. – goldilocks Dec 31 '14 at 14:29
  • No input at all, not even a LAN-cable nor HDMI nor VGA. I wrote a new downloaded Raspbian image to the file and even tried older versions that worked before with the same microSD type. I wish it would blink more, as those patterns are well documented but I cannot find any documentation for 2 blinks, so I don't know whats wrong. :( – NaCl Dec 31 '14 at 14:38
  • 2 blinks is what it does normally, and it will not blink at all if you remove the SD card. But I have not found documentation for exactly what it means either. Did you drop it? – goldilocks Dec 31 '14 at 14:47
  • No, there was no drop or anything like that. It was lying in a box for about 2 weeks working and then magically it stopped and here we are. – NaCl Dec 31 '14 at 14:49
  • 1
    What about the LAN lights? If those go up, it's established a low level ethernet connection, meaning the kernel is running (this does not mean it's actually connected to an IP network tho). – goldilocks Dec 31 '14 at 14:51
4

Just to put in answer form. Per official raspberry pi site, the dd command should be

 dd bs=4M if=2014-09-09-wheezy-raspbian.img of=/dev/mmcblk0

Edit: obviously changing image name to that of your image.

  • so bs=4M is needed... – NaCl Jan 1 '15 at 17:05
  • But you got it working though right? – geoffmcc Jan 1 '15 at 17:07
  • yes it works now. Adding bs=4M fixed it – NaCl Jan 1 '15 at 17:07
  • Okay cool. I read your comment wrong at first and thought you said bs=4 wasnt needed. Glad your up and running..... If you have a USB drive to spare, I would move file system to USB so it will perform better and not burn out your SD card. If interested check out raspberrypi.org/forums/viewtopic.php?f=29&t=44177 but powered drives work better than thumb drives. Plus you can over clock to turbo and not worry about slow SD read/write speeds giving you issues – geoffmcc Jan 1 '15 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.