My external USB HDD becomes repeatedly inaccessible after a long time of usage/idleness. The same thing happened before with a very old disk and I thought it was just failing. But I do have the same issue with a new set-up.

I get errors like the following and I have to physically remove the disk from its power supply to get it to work again.

usb 1-1.3: device descriptor read/64, error -71
Device offlined - not ready after error recovery
[sda] Unhandled error code

Full log

I'm suspecting some kind of power issue - I heard old RPis do have them. The RPi is plugged into a 2 slot PSU, the HDD is connected with a Y-cable to the same PSU and the RPi. I thought I might get actually less voltage problems when they draw from the same source. I also tried a powered USB hub, but that didn't quite work.

My problem is similar to this Question, but that persons solution is my current state of affairs...

There is also a very old thread on the Ubuntu forums regarding usbcore module options autosuspend and old_scheme_first here I didn't test that yet, because it takes several hours or days for the problem to occur...

Any ideas? Or is it fixed for newer versions of Rpi? Some additional infos:

RPi B, Revision: 0002 (pre-ordered it when it came out)

External USB HDD Western Digital Elements 2,5":

Bus 001 Device 010: ID 1058:10a8 Western Digital Technologies, Inc.

Mounted with:

/dev/sda1 /media/athena ext4
rw,relatime,errors=remount-ro,commit=30,data=ordered 0 0
  • What's the amperage on the PSU? You don't have to wait for the problem to happen before you try the old_scheme_first and autosuspend thing although you probably have to reconnect the drive afterward. I would try just the first one and if it happens again, then turn off the autosuspend.
    – goldilocks
    Jan 1, 2015 at 21:04
  • It's 1A. Yes, I can try it now, but I'll have to wait and see if it has any effect :) Jan 3, 2015 at 19:06
  • That PSU is too small! The pi is going to consume 700+ mA, and the drive could be up to 500. Something is bound to brown out occasionally.
    – goldilocks
    Jan 3, 2015 at 19:22
  • Hmm, makes sense. But I just stress tested my pi (with 'stress'), getting the cpu utilization to 100% for a while and using the HDD via rsync. That should max out the PSU, but it worked just fine. All stable 0.o Jan 4, 2015 at 12:33
  • Did you get a solution for this yet. I have the same problem? Feb 22, 2016 at 15:05


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.