0

I have connected Raspberry Pi to GSM sim900a mini with the following details:

  • convertor max3232 used
  • DB9-2 sim900a connected to DB9-3 max3232
  • DB9-3 sim900a connected to DB9-2 max3232
  • tx (raspberry) connected to tx (max3232)
  • rx (raspberry) connected to rx (max3232)

But there's no respond through miniterm.py as I run the command below:

sudo miniterm.py /dev/ttyAMA0

I don't Know why the transfer (send/transfer) is not working.

Sim900A MAX3232

migrated from electronics.stackexchange.com Jan 2 '15 at 0:17

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

1

I have figured out that I can connect to the Raspberry using the UART interface directly. I was using the rs232.The problem is solved then.

0

have you set baud rate i think 9600,

I don't have idea about miniterm.py, but try to install minicom.

then minicom -s for setting all configuration

and then save as default and then go on, I set up is fine..

and also have you enabled uart in your pi?? if no follow www.robot-electronics.co.uk/files/rpi_serial_setup.doc.

  • Thank you RahulAN for your reply. Yes the baud rate is 9600. And the uart is enabled. I have found my problem and will post the answer soon. – Maria Jan 3 '15 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.