I'm running a Raspberry Pi in my local network with Raspbian. Until now, it used DHCP to obtain its IP adress from my router. I wanted to switch to a static IP for the Pi, to be able to connect to it using the same IP after every reboot (which seems to work so far, as I am able to connect to it via ssh). I'm using xrdp to connect to the Pi to be able to use the graphic interface from a Windows Remote Desktop Connection.

Since changing to a static adress, I seem to no longer be able to properly connect to xrdp. The login window shows and as soon as I want to connect, the following error message is displayed:Error Message

As soon as I login to the Pi using SSH, the xrdp session doesn't show this error message again, but now shows a grey desktop, with a black X as a cursor.

Changing back the network setup to use dhcp again doesn't resolve the problem either.

How can I get xrdp back to work?

  • what is the static IP you set? Also, 127.0.0.1 is the localhost ip so it appears that you are trying to connect to your pi using the localhost address. This would be equivalent to the windows machine talking to its self. – Steve Robillard Jan 3 '15 at 19:40
  • The static IP I set is 192.168.178.22, the shown message is from the session manager on the Pi. So actually, the local loopback is wanted, as the session-manager tries to connect to the session locally. – Dschoni Jan 3 '15 at 20:57
  • Have you rebooted the pi after changing IP address? Does the XRDP client have a log or verbose option that expands on the error? – Steve Robillard Jan 3 '15 at 21:03
  • Yes I have rebooted. As already mentioned, I can connect via SSH and to the session manager as well. Only the internal connection from the session manager to the session itself seems not to work. I did not find neither a log nor a verbose option. – Dschoni Jan 3 '15 at 22:45
  • try running "xhost 192.168.178.22" on the Pi before connecting. – rob Jan 5 '15 at 9:51
up vote 0 down vote accepted

Actually I found the answer beeing something pretty more simple than I thought. I had an upstart job producing enourmous amounts of log data, that spilled the harddisk. So the missing harddisk space was the reason for the session not to be able to be created and so the manager couldn't connect to it. Since cleaning some space on the HDD, everything works again!

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.