0

I have a b-link wireless adaptor, and I have tried many ways of installing drivers for it to run on my raspi but I can't find any way successfully. One of the drivers I found and tried is here, I believe that it's the proper driver for my wireless adaptor, however, while installing it by following the instructions provided by the author, I always got this:

make -C tools
make[1]: Entering directory '/home/pi/Downloads/mt7601-master/src/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/pi/Downloads/mt7601-master/src/tools'
/home/pi/Downloads/mt7601-master/src/tools/bin2h
cp -f os/linux/Makefile.6 /home/pi/Downloads/mt7601-master/src/os/linux/Makefile
make -C /lib/modules/3.12.28+/build SUBDIRS=/home/pi/Downloads/mt7601-master/src/os/linux modules
make[1]: Entering directory '/lib/modules/3.12.28+/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/lib/modules/3.12.28+/build'
Makefile:394: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2

and was unable to install the drivers, is there anyone could tell me what's wrong with my installation or give me some advice on how to install such drivers on raspi?

  • I recently loaded my second Pi B+ running Rasbian. I did not need to manually load any drivers. I simply plugged the mini usb adapter, and, Raspbian took care of it from there. – rrirower Jan 5 '15 at 19:25
1

Your best bet may be to find binary drivers that'll work for you, instead of compiling them.

I'd bet there's no /lib/modules/3.12.28+/build, which should be a symlink to the linux headers that are part of the kernel source. You'll need to install them.

Raspbian is a bit special, it doesn't look like there's a package you can install with apt-get.

edited to add I found that I could update the kernel using rpi-update and then used rpi-source to install the kernel source, which includes the headers. It does require a reboot, and I had to upgrade gcc as well, but that's all outlined in the links I included.

After I did that, I was able to compile the driver the original poster was having trouble with. Whether or not this is the correct driver for the OP's wireless adapter is another question. :-)

  • Yeah, the special status of the rpi kernel throws a big wrench into this for new users. This may be of interest, although I don't say much more than you already have here. – goldilocks Jan 5 '15 at 19:52
  • @mazianni, I did the instructions you provided, but still got the same errors I mentioned above, what should I do? How can I check out whether I did what you provided in the right way? Waiting for your help... – chinashieh Jan 7 '15 at 11:59
0

@chinashieh I apologize for the lateness of the reply. If you got the exact same errors when compiling, you either don't have the linux headers installed or you don't have the correct headers. Does /lib/modules/3.12.35+/build exist?

pi@kd-pi ~ $ ls -ld /lib/modules/3.12.35+/build lrwxrwxrwx 1 root root 11 Jan 5 14:07 /lib/modules/3.12.35+/build -> /root/linux

If not, then you may not have installed the kernel source as outlined in the rpi-source link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.