2

How can I remap my keyboard it is on a Motorola lapdock 100 The @ " / |# are all in the wrong place I have tried Sudo Dpkg-reconfigure keyboard-configuration but Motorola is not in the list any where.and these keys any vital to programming.

  • Your "Motorola" keyboard is almost certainly not a custom layout unique to that manufacturer but is using one of the standard layouts such as "US" or "Canadian French." If you can post a picture of your keyboard, or at least describe where some of the keys (letters and punctuation) that print wrong are located (e.g., does the '2' key above the 'W' key have an @ sign or a " (double quote) on it?) we can probably tell you which particular layout you need to set. – Curt J. Sampson Apr 16 '17 at 11:28
1

It may be simpler to use raspi-config

sudo raspi-config

Select the internationalisation option and change keyboard layout.

  • That just runs the same comand – Jhondoe Jan 6 '15 at 17:47
  • @Jhondoe So which keyboard layout did you choose? – joan Jan 6 '15 at 17:53
  • Non as non of them are even by Motorola and a can not afforded to mess it up as I am making a master image to roll out to 40 sd cards – Jhondoe Jan 6 '15 at 17:56
  • 1
    @Jhondoe My memory of how a keyboard layout is chosen was wrong. I suggest you try one of the generic options. – joan Jan 6 '15 at 18:09
  • 2
    No options for Generic 101-key PC, Generic 102-key (Intl) PC, Generic 104-key PC, Generic 105-key (Intl) PC? – joan Jan 6 '15 at 18:57
1

By default the Raspbian operating system comes configured to recognise and use a keyboard with a Great Britain (GB) character set. If we want to change the default keyboard to something else (for example a US keyboard, or a similar model to that required) we will need to edit the keyboard configuration file.

So, from the command line execute the following command;

sudo nano /etc/default/keyboard

This will present the keyboard configuration file which will look something like the following;

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Edit the file to implement the United States character keymapping by changing the file to the following;

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Then we need to reboot the Pi to let the changes take effect;

sudo reboot

To manage the keyboard you are looking for you might need to make a few trials to get it right

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.