22

I'm starting work on a fermentation monitor using the Adafruit temperature sensing tutorial, a RPi B+ running Raspbian, a 4.7 kOhm resistor and a DS18B20 to which I've soldered male breadboard pins. After wiring exactly as the tutorial states (on multiple breadboards), I do:

sudo modprobe w1-gpio
sudo modprobe w1-therm
ls /sys/bus/w1/devices

But I only get a folder named "w1_bus_master1"; no 28-xxx folders. I understand this is a common question, so here is what I have done so far:

  • This DS18B20 has worked (and still works) when connected to my Arduino, so the sensor is not faulty.

  • Tried connecting the sensor to the 5V GPIO with no success.

  • Tried wiring the resistor as it is on my Arduino's breadboard, with the power/data/ground on one column, the power/data resistor on the next column, and the sensor pins on the column after that; no luck.

  • Tried using the same wiring on multiple breadboards.

Any ideas where I'm going wrong?

A picture of the connections.

  • 1
    A photo and a precise description of the connections between the Pi and sensor (including the resistor connections) may be useful. – joan Jan 8 '15 at 10:00
  • As far as I can tell the connections seem correct. Ground - Ground, 3V3 - Power, gpio 4 - data, data pulled up to 3V3 via resistor. – joan Jan 8 '15 at 14:03
  • I've just set one up and it works fine. The obvious error is swapping the ground and power connections. – joan Jan 8 '15 at 14:26
  • What version are running? In the terminal type uname -a – user26736 Feb 6 '15 at 19:39
  • Related: DS18b20 temperature sensor not listed. – Ruslan Nov 19 '17 at 19:25
28

Found it!

sudo nano /boot/config.txt

add :

dtoverlay=w1-gpio

this has to do with kernel update, find more info in this link

  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Steve Robillard Feb 11 '15 at 21:35
  • Hell yeah! I was really struggling with this! I had a working Pi2 with a 10-probe 1-wire network. I made a new network with a Pi3 and couldn't get it to work even with the sensor cluster from the old Pi2. If I could give you more than +1 I would. Thanks, this worked a charm! – Jim Aug 28 '17 at 6:45

protected by Community Mar 21 '15 at 22:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.