2

as the title says I had my pi working but can't even get it to recognise the adapter now (same adapter).

I originally set it up with the GUI, but since it no longer had the adapter in the list I tried to configure it manually.

The interesting thing is if I run sudo iwlist wlan0 scan |grep ESSID

it shows me a bunch of wi fi networks...so it must be working right? My router uses WPA.

here is my wpa_supplicant.conf file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={ 
ssid="ssidhere"
psk=""pass here"

}

and network/interfaces

allow-hotplug wlan0
iface wlan0 inet maunal
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Would really appericiate any help or advice.

Thanks, Matt

  • How are you powering the Pi, and is the wifi dongle plugged into a powered usb hub? "It was working" for how long? – Steve Robillard Jan 8 '15 at 20:56
  • I bought a model B starter kit which came with everything. The Pi is powered by the mains plug that came with it (looks like my android smart phone one) and the usb plug is tiny and just plugged straight into the pi. – Matt Boyle Jan 8 '15 at 20:57
  • U may need a usb powered hub as the power required for wifi adapter in not sufficient – prince Jan 9 '15 at 8:12
  • I am sorry but I do not think that is correct. It worked initially and the adapter was bundled with the pi. It is a ralink one. Further more if you read my post it seems it is being recognised – Matt Boyle Jan 9 '15 at 10:40
  • You have "manual" spelled incorrectly in the /etc/network/interfaces listing. Is that a copy & paste? – bobstro Oct 7 '15 at 1:11
2

I second the power comment. I too have had "working" Pi configurations that suddenly started showing problems after months. In my case I was running edimax wifi and shairport for apple airplay support. The bandwidth was always marginal, but it worked. One day the wifi died, and I ultimately determined that a better wall wart solved the problem and improved throughput. USB power is the Pi's Achilles heel. You may also improve the situation by unplugging other USB devices (keyboard).

2

it shows me a bunch of wi fi networks...so it must be working right?

Yep, you would not be able to scan for wifi networks without a working wifi adapter.

Try:

service networking stop
dhclient -r 
wpa_supplicant -B -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0
dhclient -v wlan0

Wait ~5 seconds between the last two commands; you'll see a bit of output that might include some inscrutable warnings but ignore that.

Now try ip addr. Hopefully, you see wlan0 listed with an associated inet address. You're not connected. If that works, leave a comment and we can possibly automate that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.