1

I've tried many ways to connect to a Hidden WiFi network from a raspberry pi but none of them seem to work. My raspberry pi is able to detect that there is a network but it cannot map it to it. I ran the following command:

pi@raspberrypi ~ $ sudo iwlist wlan1 scan essid "MYSSID"
wlan1     Scan completed :
      Cell 01 - Address: //redacted//
                ESSID:"Not my wifi"
                Protocol:IEEE 802.11bgn
                Mode:Master
                Frequency:2.437 GHz (Channel 6)
                Encryption key:on
                Bit Rates:65 Mb/s
                Extra:wpa_ie=//redacted//
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (1) : TKIP
                    Authentication Suites (1) : PSK
                Quality=58/100  Signal level=100/100
      Cell 02 - Address: //redacted//
                ESSID:"Some other wifi"
                Protocol:IEEE 802.11bgn
                Mode:Master
                Frequency:2.437 GHz (Channel 6)
                Encryption key:on
                Bit Rates:65 Mb/s
                Extra:wpa_ie=//redacted//
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (1) : TKIP
                    Authentication Suites (1) : PSK
                Quality=54/100  Signal level=23/100
      Cell 03 - Address: //redacted//
                ESSID:""
                Protocol:IEEE 802.11bgn
                Mode:Master
                Frequency:2.437 GHz (Channel 6)
                Encryption key:on
                Bit Rates:130 Mb/s
                Extra:rsn_ie=//redacted//
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : CCMP
                    Pairwise Ciphers (1) : CCMP
                    Authentication Suites (1) : PSK
                Quality=100/100  Signal level=42/100

Any insight of how I could connect to it would be greatly appreciated.

Edit:

my /etc/network/interfaces

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
    address 10.10.10.2
    netmask 255.255.255.0
auto lo
iface lo inet loopback

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface wlan1 inet dhcp
up iptables-restore < /etc/iptables.ipv4.nat

my /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


network={
        ssid="MYSSID"
        scan_ssid=1
        mode=0
        proto=WPA2
        pairwise=TKIP
        group=TKIP
        key_mgmt=WPA-PSK
        psk="password"
}

I tried both ways to connect to the network, I added the contents of the file.

Another thing I noticed while testing with other Hidden networks is that, if I run the essid scan on them, if the hidden network is picked up only then is the Pi able to establish a connection.

  • Include the contents of /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf – Milliways Jan 9 '15 at 0:43
1

Your /etc/wpa_supplicant/wpa_supplicant.conf looks OK and includes the scan_ssid=1 which should have it scan hidden networks, but you never call it.

Include the following in your /etc/network/interfaces

allow-hotplug wlan1
iface wlan1 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

This is pretty much the normal setting of this file.

I do not know the detail of the parameters you have in your /etc/network/interfaces, but they do not seem the same as those in /etc/wpa_supplicant/wpa_supplicant.conf

It is better practice to include security detail in /etc/wpa_supplicant/wpa_supplicant.conf as only root can view it.

  • Sorry, I didn't realize I pasted the wrong file, I was trying something. I pasted the version that I was trying before hand with wpa_supplicant.conf – hidden_ssid_woes Jan 9 '15 at 3:15
0

Did you get it working?

These instructions did it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.