I've just started dabbling with my RPi (model B) and I want to send the IR codes that I've captured using an IR-Receiver with lirc - irrecord application.

The creation of the configuration file has been completed successfully.
I can verify this, because when I run this:
irsend LIST philips ""
I get the list of the keys I've captured.

The problem is that I don't know much about electronics, so I am not sure I've set up correctly the transmitter.

I've tried this schematic for the transmitter, and made the IR led "look" towards the device (or even my receiver) and couldn't get any results.

I've also tried this schematic (without the R2 resistance - it is said at the post, that he omitted it), and had no results.

Do you have any possible ways to troubleshoot this?

1 This is the current state (following the 1st schematic):
above view of the circuit
close view of the transistor/resistor/IR-Leds

Also, this is the config file that was created with irrecord:

begin remote

  name  philips
  bits           13
  eps            30
  aeps          100

  one           885   879
  zero          885   879
  plead         892
  gap          113079
  toggle_bit_mask 0x0

      begin codes
          KEY_POWER                0x1D4C 0x154C
          KEY_VOLUMEUP             0x1C10
          KEY_VOLUMEDOWN           0x1411
          KEY_TUNER                0x1C7F
          KEY_NEXT                 0x1C60 0x1460
          KEY_PREVIOUS             0x1461
          KEY_MUTE                 0x140D
      end codes

end remote

This is the output of irsend LIST philips "":

irsend: 0000000000001d4c KEY_POWER
irsend: 0000000000001c10 KEY_VOLUMEUP
irsend: 0000000000001411 KEY_VOLUMEDOWN
irsend: 0000000000001c7f KEY_TUNER
irsend: 0000000000001c60 KEY_NEXT
irsend: 0000000000001461 KEY_PREVIOUS
irsend: 000000000000140d KEY_MUTE

I am using this irsend SEND_ONCE philips KEY_POWER and get no results.

  • 1
    Perhaps a close-up photo of the connections you are actually using accompanied by a description would be helpful. The command you issue and the expected response may also be relevant.
    – joan
    Commented Jan 9, 2015 at 23:52
  • @joan I've updated my post with as many as possible information, hope this will help! Thank you for your time :)
    – Chris
    Commented Jan 10, 2015 at 0:10
  • May I suggest you download my pigpio and piscope to monitor the activity. It should show the waveform you are transmitting on the IR. Also if it is tuned to the same carrier as the receiver (and pointed towards it) you should pick up the same signal on the receiver.
    – joan
    Commented Jan 10, 2015 at 10:05

3 Answers 3


One handy trick to troubleshoot IR LEDs is that your phone camera can "see" the light from them. SO to test the operation of the circuit (or the operation of a TV remote), point it at your phone camera while you are viewing the image on your phone's screen, and you will be able to see the (normally invisible) infrared light.

As you say, substituting "ordinary" visible LEDs in the place of the IR LEDs can help you see whether the circuit is working reliably. This way you can more quickly rule out things like others have suggested, including having them inserted backwards, or having the wrong resistance in the circuit.

Writing a simple program that just toggles the GPIO pin slowly (maybe 2 seconds high, 2 seconds low) might be helpful, too. That way you can easily measure the voltages in the circuit using a voltmeter.

  • Thanks for this tip Tommy! Although, what I've done is to connect a simple led along with the IR Receiver, so if I get any input there, the led lights up. In my case, when I issue the irsend command I cannot see anything there, so something might be wrong with the IR transmitter circuit?
    – Chris
    Commented Jan 10, 2015 at 23:38
  • It's pretty easy to burn up LEDs, including IR types. I killed a couple normal LEDs just a bit ago with too much voltage because I misread bands on a resistor. @tommyTrussell nice trick..I'm shocked I didn't know that.
    – Tyson
    Commented Jan 11, 2015 at 3:11
  • I agree with @Tyson it's possible to burn out LEDs especially when you aren't using a resistor to keep the voltage under control, but that wouldn't necessarily be the first thing I would look for. A voltmeter (even a cheapo one from your local auto parts or hardware store) might be useful to verify that you're turning on and off the GPIO and getting voltages in the range you expect them. Unfortunately using the irsend program would probably toggle the circuit too quickly to read using a simple voltmeter, so you might have to write a simple program to run instead. Commented Jan 11, 2015 at 5:22
  • Commenting on old post - but suffering same fate, in my case I had burnt out the LED. Replacing with a resister solved the problem.
    – kirgy
    Commented Sep 6, 2016 at 22:42

From the image it appears you're using two LEDs in series; correct? If so, make sure the voltage that the IR leds take aren't above 2,5 volts (not sure what their rating is) because in that case a 5V supply voltage won't light them up.

I'd try to have the LEDs burn first so just reconnect them directly to +5V (through the same resistor of course!) and use a camera on a phone to verify they burn. Please test that with a normal remote as well; my iPhone's camera will NOT show IR light, but the front camera will (!)


Is it possible you have the LEDs in backwards. LEDs must be placed in the correct orientation or no current will flow (i.e. they don't light up).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.