2

I've just gotten my Raspberry Pi B+ yesterday and wanted to get into simple scripting with the GPIOs after installing a Raspbian(minimal net install with raspbian-ua-netinst since the SD card was too small for the full raspbian and I really don't need/want an X server). So the first thing I wanted to do was to let a simple LED blink with Python.

I set up a script that lights GPIO 4 and connected the pin to a LED, followed by a resistor and going back to ground. The only thing I get with this setup is a dim light which won't change. This seemed strange so I tried another port - this time nothing was happening at all, the LED stayed off. When I connect the LED to the 3V pin the LED works just fine.

After a bit of fiddling I changed from Python to pure sysfs calls. I exported the GPIO, echoed out to the direction file and echoed 1 to value. Nothing changed. I tried several pins but it was always the same - either the pin gave me a dim light or no light at all and they never change.

I then measured the voltage between the GPIOs. I got 3.3V on the 3V GPIO and on GPIO 4 and one or two other pins, and 0V on several others. I also tried 3V to an input GPIO - the voltage that came through was okay but it did not respond.

When measuring the voltage of 5V to GND my multimeter gives me between 4.96 and 4.99V.

When running the test script from the WiringPi gpio directory it reports 8 pins not working and then the Pi goes into an ugly state where neither LAN nor USB work at all.

Is something broken in the hardware or might this just be a software issue? It's new hardware and a fresh install and apt reported no new updates but I'm not sure if I'm missing some important package since it was installed with the netinstaller.

  • 1
    If you are lucky it's just a poor power supply. What voltage (carefully) do you measure between pin 2 (5V) and pin 6 (ground)? – joan Jan 11 '15 at 0:14
  • I've edited my question and added the 4.96V that measurement gave me. – Izzy Jan 11 '15 at 18:41
  • That should be enough :( As with most other things, I imagine some of them do get shipped out defective, unfortunately, but the distributor should be willing to take it back or replace it. – goldilocks Jan 11 '15 at 21:47
  • I just found that at least one GPIO pin on my RPi 1 B+ is dead after the RPi fell off my table and landed on the floor... :( besides the GPIO the board seems to be working OK... strange. – Kozuch Oct 4 '15 at 13:49
1

To exlude the possibility of a poor power supply as suggested by joan I measured the voltage between pin 2(5V) and pin 6(GND).

After measuring the Voltage of every GPIO pin with output set to 0 and 1, setting up a test with LEDs on every GPIO and running the test-script provided in the gpio folder of WiringPi and using WiringPi's gpio readall I came to the conclusion that the GPIO pins of this Raspberry Pi are dead and the Pi will be send back for a replacement.

Edit: After testing a replacement with the same USB cable, the same µSD card and the exact same test setup(simple LED to GPIO pin) it is now clear, that all GPIO pins on the first Raspberry Pi are dead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.