4

I plugged in my RPi B+ (with latest Raspbian) to a speaker (August SE30, using the analog jack). I get the expected sound when using mpg123 but I also get, when not playing, a continous stream of noise which shadows the RPi activity. You can hear how it changes during the boot phases, then with any activity (downloading something, actions on the SD, etc.).

I tried a different power source and signal cable. It does not seem to be related to the issue which was fixed with a recent firmware (I upgraded everything). The bluetooth audio connection does not have this problem (but I would like to avoid using it for other reasons).

My question is whether this noise is expected (for instance due to some interferences between the analog converter and some other element in the RPi, or any other known reason) or if it should not be the case.

If it is expected then I will invest in a USB audio card, but would prefer to be sure beforehand.

  • This is not a duplicate: the noises are not every second or so but shadow the RPi activity. It is a constant stream modified by wgatever the RPi is doing at a given time (sounds like a pitched-down modem noise, this is the closest I can imagine) – WoJ Jan 11 '15 at 15:12
  • In my case the relative volume is not very low and he also mentions that the noise does not happen with two RPis. Nevertheless it looks like I will have to look at the USB audio card. Thanks. – WoJ Jan 11 '15 at 17:45
  • Alright, I'll reopen this and delete my comments. You should edit in that fact about the relative volume so that it's clear this probably is something unusual. – goldilocks Jan 11 '15 at 18:10
3

The audio that comes out of the RPi's audio jack is awful unless you're expecting it to sound like a person half dead talking. Any moderate volume will be bad. I honestly don't remember what mine sounded like other than I wanted to kill myself when I heard it.

Some things that might help:

Add a magnetic degaussing filter to clean the interference from USB power (You should have it if you use a USB soundcard too) : http://goo.gl/SqZYSc

Load up alsa mixer and set the volume low and use an external amp.

Alternatives -Use the HDMI port for audio -Get a sound card. The sounds quality is day and night. I use : HiFimeDIY Sabre USB DAC ES9023 96Khz/24bit

  • did you check the magnetic degaussing filter? – Maoz Zadok Apr 15 at 5:43
1

Noise can be induced by

  • a power supply unit, try another one or a filter as @Brendon suggested
  • peripheral devices such as wifi stick, USB HDD, flash drives, etc. Try to plug them in through usb extension cable, not directly
  • overclocking might add to this effect

Playing audio through USB/HDMI will definitely help.

More info: http://www.howtoeverything.net/linux/raspberry-pi/sound-distortions-and-raspberry-pi-reasons-and-solutions

1

There are several issues relating to this noise. Part of it is probably bad isolation between the digital system generating the audio (pulse width modulation directly out of the chip) and the active system you have in place.

A lot of people suggest to use USB sound cards, however there are some great GPIO header based sound cards available as well, such as these here. Some of these will have great analogue/digital separation with dedicated supplies for separation of noise.

If you have a look at the Pi schematic here, you will notice that the aud_3v3 line is supplying the NC7W16 chip with power. The chip iteself is nothing other then a 1 bit digital buffer. This chip is also connected to digital ground. How the aud_3v3 supply is derived is not specified on the schematic. It is likely that it is derived from the digital supply simply with a ferrite bead which is a high pass filter. Based on this assumption, acoustic frequency digital noise is still present on the AUD_3V3 power and as there is no real segmentation of the power for the audio subsystem, this noise is still present on the analogue output, which you most likely hear.

For that reason I have linked you to some sound cards, most of which will have specific linear regulators for dedicated low noise analogue power.

Matt

  • Could you please include some specific detail in your answer, link only answers are generally discouraged. – Darth Vader Sep 3 '16 at 8:36
  • Thanks for the feedback Darth. I have now explained how the digital noise is most likely present on the analog line - referencing the Pi 3 schematic. – Matt Sep 4 '16 at 11:06
0

I've got the same problem and find a tricky resolution :

pull out the jack about 1 or 2mm !

No loose of volume and no more noise.

  • 1
    Sorry, but this isn't a solution whatsoever! – Alex Holsgrove Jul 14 '16 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.