2

Ok so I've decided to make some use of my raspberry pi and make it into an ssh server that will compile cpp for me from my phone, it was awesome, until I changed the overclock back to normal seeing an ssh server doesn't need to be overclocked and rebooted it from my phone's ssh app (juicy ssh) and I logged back on from the pi not ssh and then changed the Unix password for me for ease of use, I tried to connect to ssh and it said it wouldn't connect and timed out, so I checked the ip using hostname -I and the ip changed, so I updated it on my app and it still failed to connect, so I unchanged the password back to the original and rebooted, also rebooted my phone, still wouldn't work, I made sure the pi the pi was connected to the internet and it still is, and it still won't connect, I don't know what to do, and I don't want to reflash the sdcard because I lack the hardware to do that, also it boots to the command line all the time

  • can you try running "sudo service ssh status" to check if the ssh daemon is running? (it should say something along the lines of sshd is running) – user2813274 Jan 20 '15 at 0:32
  • Yes it is running, it says it's running every boot, and the ip you can connect to it with, if it's 192.168.1.144 then it won't work, but if it's and ip that ends with .0.36 then it works – Bob_the_rhino Jan 20 '15 at 3:13
  • Are you using wifi or network data connection? – Bex Jan 20 '15 at 8:17
  • Wifi, via dongle – Bob_the_rhino Jan 20 '15 at 13:32
  • And it is connected to the internet, I can ping ips, and goto websites – Bob_the_rhino Jan 20 '15 at 13:42
3

Try to ssh into the Pi from a system which tells you why it will not connect.

For instance from a Linux box try ssh -v host for verbose output or ssh -vv host (two v's, not a w) for extremely verbose output.

The crux of the matter is probably the IP address change. Of course ssh won't connect if the IP address has been altered, that would be pretty much a man-in-the-middle attack.

Normally ssh would warn you and offer to update its records if you trust the new IP address.

| improve this answer | |
  • It actually worked last night again because it changed ips again, but then it stopped working while it was idling and I restarted again and the ip changed again, is there a type of bare bones os that I can install to the pi that will make it's primary function to be a ssh server? – Bob_the_rhino Jan 18 '15 at 19:18
  • I tried by connecting using putty and it just timed out and didn't give me any other info – Bob_the_rhino Jan 18 '15 at 19:24
  • I tried to make a static ip with the one that's know to work (ends with .0.36) and it still defaults to the ip of 192.168.1.144, I read somewhere that people are having he same problem with ssh not working with this ip – Bob_the_rhino Jan 20 '15 at 1:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.